summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-08 11:58:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-09 14:30:38 +0200
commit2e3efa6e558ea7adf6980e6f07c002a59597ad51 (patch)
tree656c18f454582c1f6bc6e3814457771e0f226d16
parentde933b71ee0a15ca4b70c8a51920f1216dbf81f5 (diff)
downloadpatches-2e3efa6e558ea7adf6980e6f07c002a59597ad51.tar
patches-2e3efa6e558ea7adf6980e6f07c002a59597ad51.tar.gz
gnu: fastahack: Update to 1.0.0.
* gnu/packages/bioinformatics.scm (fastahack): Update to 1.0.0.
-rw-r--r--gnu/packages/bioinformatics.scm53
1 files changed, 26 insertions, 27 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6dc313199b..76026e7065 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15055,37 +15055,36 @@ neural networks.")
(license license:gpl3))))
(define-public fastahack
- (let ((commit "c68cebb4f2e5d5d2b70cf08fbdf1944e9ab2c2dd"))
- (package
- (name "fastahack")
- (version (git-version "0.0.0" "1" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ekg/fastahack/")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0hfdv67l9g611i2ck4l92pd6ygmsp9g1ph4zx1ni7qkpsikf0l19"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; Unclear how to run tests: https://github.com/ekg/fastahack/issues/15
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; There is no configure phase.
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
- (install-file "fastahack" bin))
- #t)))))
- (home-page "https://github.com/ekg/fastahack")
- (synopsis "Indexing and sequence extraction from FASTA files")
- (description "Fastahack is a small application for indexing and
+ (package
+ (name "fastahack")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ekg/fastahack/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rp1blskhzxf7vbh253ibpxbgl9wwgyzf1wbkxndi08d3j4vcss9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; Unclear how to run tests: https://github.com/ekg/fastahack/issues/15
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There is no configure phase.
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "fastahack" bin))
+ #t)))))
+ (home-page "https://github.com/ekg/fastahack")
+ (synopsis "Indexing and sequence extraction from FASTA files")
+ (description "Fastahack is a small application for indexing and
extracting sequences and subsequences from FASTA files. The included library
provides a FASTA reader and indexer that can be embedded into applications
which would benefit from directly reading subsequences from FASTA files. The
library automatically handles index file generation and use.")
- (license (list license:expat license:gpl2)))))
+ (license (list license:expat license:gpl2))))
(define-public vcflib
(let ((commit "5ac091365fdc716cc47cc5410bb97ee5dc2a2c92")