summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrant Gardner <mail@lnklnx.com>2019-12-25 10:11:41 -0600
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-09 18:21:19 +0100
commit2c50e52ab8228634ce1626dc174970f4a4321d61 (patch)
tree07d624d5a4e805b923a45795cabe7300d1026028
parent29ae18db0578bbdbc0119703f7412fe91927e80e (diff)
downloadpatches-2c50e52ab8228634ce1626dc174970f4a4321d61.tar
patches-2c50e52ab8228634ce1626dc174970f4a4321d61.tar.gz
gnu: emacs-ledger-mode: Fix autoload failure.
* gnu/packages/finance.scm (emacs-ledger-mode)[arguments]: Replace the 'relocate-elisp' phase by a 'patch-site-dir' phase to put the files in the right directory and a 'generate-autoload' phase to make the autoload file. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/finance.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index ce3033c054..b24a9bfbf1 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -288,6 +288,12 @@ in ability, and easy to use.")
#:tests? #f ; there are none
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-site-dir
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("DESTINATION share/emacs/site-lisp/ledger-mode")
+ "DESTINATION share/emacs/site-lisp"))
+ #t))
(add-before 'build 'patch-path
(lambda* (#:key inputs #:allow-other-keys)
(let ((ledger (assoc-ref inputs "ledger")))
@@ -303,17 +309,12 @@ in ability, and easy to use.")
(invoke "makeinfo" "-o" target
"../source/doc/ledger-mode.texi"))
#t))
- (add-after 'install 'relocate-elisp
+ (add-after 'install 'generate-autoload
(lambda* (#:key outputs #:allow-other-keys)
(let* ((site-dir (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp"))
- (guix-dir (string-append site-dir "/guix.d"))
- (orig-dir (string-append site-dir "/ledger-mode"))
- (dest-dir (string-append guix-dir "/ledger-mode")))
- (mkdir-p guix-dir)
- (rename-file orig-dir dest-dir)
- (emacs-generate-autoloads ,name dest-dir)
- #t))))))
+ "/share/emacs/site-lisp")))
+ (emacs-generate-autoloads ,name site-dir))
+ #t)))))
(inputs
`(("ledger" ,ledger)))
(native-inputs