summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-01-10 09:52:20 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-10 11:42:05 +0100
commit230e5db71ef53e03aa623940225cc6f0b0f23440 (patch)
tree1753f3099bd71f306ec5255dba87a6b295061650
parent8a6c5b5d99f8e962d0eb719bbd0e0273b5ff499a (diff)
downloadpatches-230e5db71ef53e03aa623940225cc6f0b0f23440.tar
patches-230e5db71ef53e03aa623940225cc6f0b0f23440.tar.gz
gnu: monero-gui: Update to 0.15.0.3.
* gnu/packages/finance.scm (monero-gui): Update to 0.15.0.3. [build-system]: Use qt-build-system. [inputs]: Remove qtwebchannel and qtx11extras. [arguments]: Merge fix-library-paths, fix-monerod-path, fix-qt-paths and fix-install-path phases into a fix-paths phase. Remove custom build, change-dir and wrap-program phases. Add configure and build-zxcvbn-c phases.
-rw-r--r--gnu/packages/finance.scm95
1 files changed, 39 insertions, 56 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index b24a9bfbf1..19f990848c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
;;; Copyright © 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 Sebastian Schott <sschott@mailbox.org>
@@ -41,6 +41,7 @@
#:use-module (guix build-system python)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system go)
+ #:use-module (guix build-system qt)
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages aidc)
@@ -603,7 +604,7 @@ the Monero command line client and daemon.")
(define-public monero-gui
(package
(name "monero-gui")
- (version "0.15.0.1")
+ (version "0.15.0.3")
(source
(origin
(method git-fetch)
@@ -613,8 +614,8 @@ the Monero command line client and daemon.")
(file-name (git-file-name name version))
(sha256
(base32
- "08j8kkncdn57xql0bhmlzjpjkdfhqbpda1p07r797q8qi0nl4w8n"))))
- (build-system gnu-build-system)
+ "1v2mk6qp7dfdj4j4cilxp0s0phfwwnmjvpvjrz6jzzlpvbnavkr0"))))
+ (build-system qt-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
@@ -634,53 +635,45 @@ the Monero command line client and daemon.")
("qtquickcontrols" ,qtquickcontrols)
("qtquickcontrols2",qtquickcontrols2)
("qtsvg" ,qtsvg)
- ("qtwebchannel" ,qtwebchannel)
- ("qtx11extras" ,qtx11extras)
("qtxmlpatterns" ,qtxmlpatterns)
("unbound" ,unbound)))
(propagated-inputs
`(("monero" ,monero)))
(arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build qt-utils)
- (guix build utils))
- #:imported-modules (,@%gnu-build-system-modules
- (guix build qt-utils))
+ `(#:tests? #f ; No tests
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (delete 'check)
- (add-before 'build 'fix-makefile-vars
+ (add-after 'unpack 'fix-makefile-vars
(lambda _
(substitute* "src/zxcvbn-c/makefile"
(("\\?=") "="))
#t))
- (add-after 'fix-makefile-vars 'fix-library-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "monero-wallet-gui.pro"
- (("-L/usr/local/lib")
- "")
- (("-L/usr/local/opt/openssl/lib")
- (string-append "-L" (assoc-ref inputs "openssl") "/lib"))
- (("-L/usr/local/opt/boost/lib")
- (string-append "-L" (assoc-ref inputs "boost") "/lib")))
- #t))
- (add-after 'fix-library-paths 'fix-monerod-path
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/daemon/DaemonManager.cpp"
- (("QApplication::applicationDirPath\\(\\) \\+ \"/monerod")
- (string-append "\"" (assoc-ref inputs "monero")
- "/bin/monerod")))
- #t))
- (add-after 'fix-monerod-path 'fix-qt-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "monero-wallet-gui.pro"
- (("\\$\\$\\[QT_INSTALL_BINS\\]/lrelease")
- (string-append (assoc-ref inputs "qttools") "/bin/lrelease"))
- (("\\$\\$\\[QT_INSTALL_BINS\\]/lupdate")
- (string-append (assoc-ref inputs "qttools") "/bin/lupdate")))
- #t))
- (add-after 'fix-qt-paths 'make-qt-deterministic
+ (add-after 'fix-makefile-vars 'fix-paths
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((boost (assoc-ref inputs "boost"))
+ (monero (assoc-ref inputs "monero"))
+ (openssl (assoc-ref inputs "openssl"))
+ (qttools (assoc-ref inputs "qttools"))
+ (out (assoc-ref outputs "out")))
+ (substitute* "monero-wallet-gui.pro"
+ (("-L/usr/local/lib")
+ "")
+ (("-L/usr/local/opt/openssl/lib")
+ (string-append "-L" openssl "/lib"))
+ (("-L/usr/local/opt/boost/lib")
+ (string-append "-L" boost "/lib"))
+ (("\\$\\$\\[QT_INSTALL_BINS\\]/lrelease")
+ (string-append qttools "/bin/lrelease"))
+ (("\\$\\$\\[QT_INSTALL_BINS\\]/lupdate")
+ (string-append qttools "/bin/lupdate")))
+ (substitute* "deployment.pri"
+ (("/opt/\\$\\$\\{TARGET\\}/bin")
+ (string-append out "/bin")))
+ (substitute* "src/daemon/DaemonManager.cpp"
+ (("QApplication::applicationDirPath\\(\\) \\+ \"/monerod")
+ (string-append "\"" monero "/bin/monerod")))
+ #t)))
+ (add-after 'fix-paths 'make-qt-deterministic
(lambda _
(setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
#t))
@@ -697,24 +690,14 @@ the Monero command line client and daemon.")
,version
,(package-version monero))))
#t))
- (replace 'build
- (lambda _
- (invoke "./build.sh")))
- (add-after 'build 'fix-install-path
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "build/Makefile"
- (("/opt/monero-wallet-gui")
- (assoc-ref outputs "out")))
- #t))
- (add-before 'install 'change-dir
+ (replace 'configure
(lambda _
+ (mkdir-p "build")
(chdir "build")
- #t))
- (add-after 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-qt-program out "monero-wallet-gui"))
- #t)))))
+ (invoke "qmake" "../monero-wallet-gui.pro" "CONFIG+=release")))
+ (add-before 'build 'build-zxcvbn-c
+ (lambda _
+ (invoke "make" "-C" "../src/zxcvbn-c"))))))
(home-page "https://web.getmonero.org/")
(synopsis "Graphical user interface for the Monero currency")
(description