summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2020-01-05 16:46:01 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-12 00:19:10 +0100
commit20b49f47e572ef5eca8e75f245b5971bb682dc74 (patch)
treee1d635af197e85473ad462995b21716951ad805d
parent3065bf8aa20ac1d13d6eb07707ae67ef88f6359f (diff)
downloadpatches-20b49f47e572ef5eca8e75f245b5971bb682dc74.tar
patches-20b49f47e572ef5eca8e75f245b5971bb682dc74.tar.gz
gnu: Add libolm.
* gnu/packages/messaging.scm (libolm): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/crypto.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index dd49c12e5b..1c6e759c83 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2018 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2018, 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2018 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
@@ -1040,3 +1040,30 @@ minisign uses a slightly different format to store secret keys. Minisign
signatures include trusted comments in addition to untrusted comments.
Trusted comments are signed, thus verified, before being displayed.")
(license license:isc)))
+
+(define-public libolm
+ (package
+ (name "libolm")
+ (version "3.1.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.matrix.org/git/olm")
+ (commit version)))
+ (sha256
+ (base32
+ "06s7rw4a9vn35wzz7chxn54mp0sjgbpv2bzz9lq0g4hnzw33cjbi"))
+ (file-name (git-file-name name version))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "ctest" "build/tests"))))))
+ (build-system cmake-build-system)
+ (synopsis "Implementation of the olm and megolm cryptographic ratchets")
+ (description "The libolm library implements the Double Ratchet
+cryptographic ratchet. It is written in C and C++11, and exposed as a C
+API.")
+ (home-page "https://matrix.org/docs/projects/other/olm/")
+ (license license:asl2.0)))