summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-01-09 13:09:19 +0000
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-01-09 13:25:35 +0000
commit1a7d58dc628a2ebf1ab1db693a4946aa2b98bd2f (patch)
tree9bc025d7133b70633bdd81652e9248e9eb5d618d
parent2604ecb3a9fc00c98359ecb6059eacfa6573e515 (diff)
downloadpatches-1a7d58dc628a2ebf1ab1db693a4946aa2b98bd2f.tar
patches-1a7d58dc628a2ebf1ab1db693a4946aa2b98bd2f.tar.gz
gnu: Add emacs-ebib.
* gnu/packages/emacs-xyz.scm (emacs-ebib): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 75914f3f25..4b5008cf0d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -12524,6 +12525,38 @@ files to be expanded upon opening them.")
"This package provides an Emacs library for parsing bib files.")
(license license:gpl3+)))
+(define-public emacs-ebib
+ (let ((commit "99bd909f47f71e024ce324981109b73a50e82fba"))
+ (package
+ (name "emacs-ebib")
+ (version "2.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/joostkremers/ebib.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "131vgl4d1j9s4055x88409w19q52x2m0x08b961hylp7yb5ljzgh"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-parsebib" ,emacs-parsebib)))
+ (home-page "http://joostkremers.github.io/ebib/")
+ (synopsis "BibTeX database manager for Emacs")
+ (description
+ "Ebib is a BibTeX database manager that runs in GNU Emacs.
+With Ebib you can create, sort and manage your .bib database files,
+all within Emacs. It supports searching, multi-line field values and
+@@String and @@Preamble definitions. Ebib integrates with (La)TeX
+mode, Org mode and other Emacs editing modes.")
+ ;; The Ebib source files are released under a BSD license with
+ ;; the exception of org-ebib.el, which is released under the GNU
+ ;; GPL.
+ (license (list license:bsd-3
+ license:gpl3+)))))
+
(define-public emacs-biblio
(package
(name "emacs-biblio")