summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-23 12:55:22 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-04 10:10:46 +0100
commit0fd6138175cb6099e2e5f3d112c3188c84b31561 (patch)
tree46504cad18c7eb5bbf4b66efa16ed3426fb08415
parent16b8aff85bcdb9799496c4a27257210cd45158e5 (diff)
downloadpatches-0fd6138175cb6099e2e5f3d112c3188c84b31561.tar
patches-0fd6138175cb6099e2e5f3d112c3188c84b31561.tar.gz
gnu: kpackage: Transfer patches from NixOS.
Transfer the NixOS patches for kpackage as of 2018-02-17: - Allow external paths. - Make QDirIterator follow symlinks. Decided to use a patch for one of the "allow external paths" changes since 'substitute*' seems not to be robust enough. * gnu/packages/patches/kpackage-allow-external-paths.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/kde-frameworks.scm(kpackage)[source]: Use it. <patch>: New phase.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/kde-frameworks.scm15
-rw-r--r--gnu/packages/patches/kpackage-allow-external-paths.patch13
3 files changed, 28 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2fed38f6b9..6d4159e167 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -859,6 +859,7 @@ dist_patch_DATA = \
%D%/packages/patches/kinit-kdeinit-libpath.patch \
%D%/packages/patches/kio-search-smbd-on-PATH.patch \
%D%/packages/patches/kmod-module-directory.patch \
+ %D%/packages/patches/kpackage-allow-external-paths.patch \
%D%/packages/patches/kobodeluxe-paths.patch \
%D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch \
%D%/packages/patches/kobodeluxe-const-charp-conversion.patch \
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 2d48661a44..89d52874b8 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1825,7 +1825,10 @@ covers feedback and persistent events.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1xbfjwxb4gff8gg0hs5m9s0jcnzqk27rs2jr71g5ckhvs5psnkcd"))))
+ "1xbfjwxb4gff8gg0hs5m9s0jcnzqk27rs2jr71g5ckhvs5psnkcd"))
+ ;; Default to: external paths/symlinks can be followed by a
+ ;; package
+ (patches (search-patches "kpackage-allow-external-paths.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
@@ -1840,6 +1843,16 @@ covers feedback and persistent events.")
`(#:tests? #f ; FIXME: 3/9 tests fail.
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ ;; Make QDirIterator follow symlinks
+ (substitute* '("src/kpackage/packageloader.cpp"
+ "src/kpackage/private/packagejobthread.cpp")
+ (("^\\s*(const QDirIterator::IteratorFlags flags = QDirIterator::Subdirectories)(;)" _ a b)
+ (string-append a " | QDirIterator::FollowSymlinks" b))
+ (("^\\s*(QDirIterator it\\(.*, QDirIterator::Subdirectories)(\\);)" _ a b)
+ (string-append a " | QDirIterator::FollowSymlinks" b)))
+ #t))
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd))
diff --git a/gnu/packages/patches/kpackage-allow-external-paths.patch b/gnu/packages/patches/kpackage-allow-external-paths.patch
new file mode 100644
index 0000000000..c1c9efde7f
--- /dev/null
+++ b/gnu/packages/patches/kpackage-allow-external-paths.patch
@@ -0,0 +1,13 @@
+diff --git a/src/kpackage/package.cpp b/src/kpackage/package.cpp
+index 5aec9fd..b15c933 100644
+--- a/src/kpackage/package.cpp
++++ b/src/kpackage/package.cpp
+@@ -820,7 +820,7 @@ PackagePrivate::PackagePrivate()
+ : QSharedData(),
+ fallbackPackage(nullptr),
+ metadata(nullptr),
+- externalPaths(false),
++ externalPaths(true),
+ valid(false),
+ checkedValid(false)
+ {