summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-01-09 04:08:30 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-01-09 04:56:01 +0300
commit076fe8462af9354e441886605243d8816be918bc (patch)
treebe1dfe9c03b9461db9468fbd1caa91d483e04c08
parentd5971d667bdc15bf86bdba80f3a5ad504d96fcf4 (diff)
downloadpatches-076fe8462af9354e441886605243d8816be918bc.tar
patches-076fe8462af9354e441886605243d8816be918bc.tar.gz
gnu: teeworlds: Fix install phase on i386 architecture.
* gnu/packages/games.scm (teeworlds)[arguments]: Fix install phase on i386 architecture.
-rw-r--r--gnu/packages/games.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index dd083259c7..1f6064d082 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4580,7 +4580,9 @@ settings.link.libs:Add(\"wavpack\")")
(let* ((arch ,(system->linux-architecture
(or (%current-target-system)
(%current-system))))
- (build (string-append "build/" arch "/release/"))
+ (build (string-append "build/" (if (string=? arch "i386")
+ "x86" arch)
+ "/release/"))
(data-built (string-append build "data/"))
(out (assoc-ref outputs "out"))
(bin (string-append out "/bin/"))