summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-12 15:31:45 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-12 15:31:45 +0200
commit1d08c01fcf31ae7ac61f4595b151355b7a197e47 (patch)
tree7f9a1378e2a6b3f197c4b165548c002e44488d95
parente1804763d00a2aa03e696a73dc3675a15acd47de (diff)
downloadpatches-1d08c01fcf31ae7ac61f4595b151355b7a197e47.tar
patches-1d08c01fcf31ae7ac61f4595b151355b7a197e47.tar.gz
gnu: Add python2-sqlite.
* gnu/packages/python.scm (python2-sqlite): New variable.
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9b9a445f38..dcfe784e57 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -20,12 +20,15 @@
(define-module (gnu packages python)
#:use-module ((guix licenses) #:select (bsd-3 psfl x11))
+ #:use-module ((guix licenses) #:select (zlib)
+ #:renamer (symbol-prefix-proc 'license))
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages gdbm)
#:use-module (gnu packages readline)
#:use-module (gnu packages openssl)
#:use-module (gnu packages patchelf)
+ #:use-module (gnu packages sqlite)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
@@ -313,3 +316,31 @@ datetime module, available in Python 2.3+.")
(define-public python2-dateutil
(package-with-python2 python-dateutil))
+
+
+(define-public python2-pysqlite
+ (package
+ (name "python2-pysqlite")
+ (version "2.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://pysqlite.googlecode.com/files/pysqlite-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0nsqqfp072rgqbls100rdvbzkjkin7li3kprhfxlfqvzf608hlqd"))))
+ (build-system python-build-system)
+ (inputs
+ `(("sqlite" ,sqlite)))
+ (arguments
+ `(#:python ,python-2 ; incompatible with Python 3
+ #:tests? #f)) ; no test target
+ (home-page "http://labix.org/python-dateutil")
+ (synopsis
+ "SQLite bindings for Python.")
+ (description
+ "Pysqlite provides SQLite bindings for Python that comply to the
+Database API 2.0T.")
+ (license zlib)))
+