summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-21 21:14:19 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-21 21:14:19 +0200
commit0352532e6a3340411f10ff9ca7475343f7df25fc (patch)
tree84dc8f88848f0aa1446af3f8c35e5187f6e48c98
parented0cdf837d74a5760608a19e128eb036eea56d9d (diff)
downloadpatches-0352532e6a3340411f10ff9ca7475343f7df25fc.tar
patches-0352532e6a3340411f10ff9ca7475343f7df25fc.tar.gz
gnu: Add python-simplejson, python2-simplejson.
* gnu/packages/python.scm (python-simplejson, python2-simplejson): New variables.
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d6d450e22f..1b20029865 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -379,3 +379,34 @@ after Andy Lester’s Perl module WWW::Mechanize.")
(license (bsd-style "file://COPYING"
"See COPYING in the distribution."))))
+
+(define-public python-simplejson
+ (package
+ (name "python-simplejson")
+ (version "3.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/s/simplejson/simplejson-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "07wsry5j44l5zzm74l4j2bvasiq8n5m32f31n2p7c68i5vc6p2ks"))))
+ (build-system python-build-system)
+ (home-page "http://simplejson.readthedocs.org/en/latest/")
+ (synopsis
+ "Json library for Python")
+ (description
+ "JSON (JavaScript Object Notation) is a subset of JavaScript syntax
+(ECMA-262 3rd edition) used as a lightweight data interchange format.
+
+Simplejson exposes an API familiar to users of the standard library marshal
+and pickle modules. It is the externally maintained version of the json
+library contained in Python 2.6, but maintains compatibility with Python 2.5
+and (currently) has significant performance advantages, even without using
+the optional C extension for speedups. Simplejson is also supported on
+Python 3.3+.")
+ (license x11)))
+
+(define-public python2-simplejson
+ (package-with-python2 python-simplejson))