summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-22 17:25:26 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-01-23 21:51:09 +0100
commitca53346dd57d57ba96d15a82dd9b2543723a4ad9 (patch)
treee3849a9191ab62c962c0154f847ae5148f6f22af
parentcdcbccd17c41d91b0173349aa8c90afece840d57 (diff)
downloadpatches-ca53346dd57d57ba96d15a82dd9b2543723a4ad9.tar
patches-ca53346dd57d57ba96d15a82dd9b2543723a4ad9.tar.gz
gnu: ocaml-cmdliner: Update to 1.0.2.
* gnu/packages/ocaml.scm (ocaml-cmdliner): Update to 1.0.2. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2ecbd50a5b..c62d1ee8ee 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1768,15 +1768,17 @@ spans without being subject to operating system calendar time adjustments.")
(define-public ocaml-cmdliner
(package
(name "ocaml-cmdliner")
- (version "0.9.8")
+ (version "1.0.2")
(source (origin
(method url-fetch)
(uri (string-append "http://erratique.ch/software/cmdliner/releases/"
"cmdliner-" version ".tbz"))
(sha256
(base32
- "0hdxlkgiwjml9dpaa80282a8350if7mc1m6yz2mrd7gci3fszykx"))))
+ "18jqphjiifljlh9jg8zpl6310p3iwyaqphdkmf89acyaix0s4kj1"))))
(build-system ocaml-build-system)
+ (inputs
+ `(("ocaml-result" ,ocaml-result)))
(native-inputs
`(("ocamlbuild" ,ocamlbuild)
("opam" ,opam)))
@@ -1785,6 +1787,12 @@ spans without being subject to operating system calendar time adjustments.")
#:build-flags '("native=true" "native-dynlink=true")
#:phases
(modify-phases %standard-phases
+ (replace 'install
+ ;; The makefile says 'adjust on cli invocation'
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (invoke "make" "install" (string-append "PREFIX=" out))
+ #t)))
(delete 'configure))))
(home-page "http://erratique.ch/software/cmdliner")
(synopsis "Declarative definition of command line interfaces for OCaml")