summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-09-29 17:21:20 -0400
committerLeo Famulari <leo@famulari.name>2018-10-02 15:40:52 -0400
commit7d15490cd247c35aeac170e2cf002d1fd93b775a (patch)
treee5d2a1110d4612c557bdc24fd279b3f7dfd1db39
parent5149857651299be32ee8dedd813b184ff1964099 (diff)
downloadpatches-7d15490cd247c35aeac170e2cf002d1fd93b775a.tar
patches-7d15490cd247c35aeac170e2cf002d1fd93b775a.tar.gz
gnu: Syncthing: Update to 0.14.51.
* gnu/packages/syncthing.scm (syncthing): Update to 0.14.51. [arguments]: Adjust the 'increase-test-timeout' phase. [inputs]: Add go-gopkg.in-ldap.v2.
-rw-r--r--gnu/packages/syncthing.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index bd7ff74b43..2e936eef7d 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -30,7 +30,7 @@
(define-public syncthing
(package
(name "syncthing")
- (version "0.14.50")
+ (version "0.14.51")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/syncthing/syncthing"
@@ -38,7 +38,7 @@
"/syncthing-source-v" version ".tar.gz"))
(sha256
(base32
- "0yjj6zzivzw289bhwqjb4xcv8p39n5mcwwr5w6xf5ykzljc5pk55"))
+ "17phn8l2afhgzh0q9ambi28awj2m905sr1bicq2wc7ghypk5vgqh"))
(modules '((guix build utils)))
;; Delete bundled ("vendored") free software source code.
(snippet '(begin
@@ -59,7 +59,7 @@
(add-before 'build 'increase-test-timeout
(lambda _
(substitute* "src/github.com/syncthing/syncthing/build.go"
- (("60s") "999s"))
+ (("120s") "999s"))
#t))
(replace 'build
@@ -138,6 +138,7 @@
("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
("go-github-com-rcrowley-go-metrics" ,go-github-com-rcrowley-go-metrics)
("go-github-com-sasha-s-go-deadlock" ,go-github-com-sasha-s-go-deadlock)
+ ("go-github-com-syncthing-notify" ,go-github-com-syncthing-notify)
("go-github-com-syndtr-goleveldb" ,go-github-com-syndtr-goleveldb)
("go-github-com-thejerf-suture" ,go-github-com-thejerf-suture)
("go-github-com-vitrun-qart" ,(go-github-com-vitrun-qart-union))
@@ -145,7 +146,7 @@
("go-golang-org-x-net-union" ,(go-golang-org-x-net-union))
("go-golang-org-x-text" ,(go-golang-org-x-text-union))
("go-golang-org-x-time-rate" ,go-golang-org-x-time-rate)
- ("go-github-com-syncthing-notify" ,go-github-com-syncthing-notify)
+ ("go-gopkg.in-ldap.v2" ,go-gopkg.in-ldap.v2)
;; For tests
("go-github-com-d4l3k-messagediff" ,go-github-com-d4l3k-messagediff)))
(synopsis "Decentralized continuous file system synchronization")