summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 22:43:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 22:48:52 +0100
commit55a0a3c853dc9177afeb9d438f3e4bdc1a1379e7 (patch)
tree818b411a6df58581fd8cace5e737b0664ffe9684
parent1f058eced3a4dad4fe0c7f46a1abcc621ffe4ce3 (diff)
downloadpatches-55a0a3c853dc9177afeb9d438f3e4bdc1a1379e7.tar
patches-55a0a3c853dc9177afeb9d438f3e4bdc1a1379e7.tar.gz
gnu: python-loompy: Update to 2.0.17.
* gnu/packages/bioinformatics.scm (python-loompy): Update to 2.0.17. [source]: Fetch via git. [arguments]: Enable tests, replace "check" phase. [propagated-inputs]: Add python-pandas. [native-inputs]: Add python-pytest.
-rw-r--r--gnu/packages/bioinformatics.scm34
1 files changed, 24 insertions, 10 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 97d2404bf3..da0edcdf40 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11945,21 +11945,35 @@ variational inference.")
(define-public python-loompy
(package
(name "python-loompy")
- (version "2.0.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "loompy" version))
- (sha256
- (base32
- "1drgv8j1hxqzzpnfg272x9djb6j8qr798w1pc2x8ikmfgyd9gh51"))))
+ (version "2.0.17")
+ ;; The tarball on Pypi does not include the tests.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linnarsson-lab/loompy.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12a5kjgiikapv93wahfw0frszx1lblnppyz3vs5gy8fgmgngra07"))))
(build-system python-build-system)
- ;; There are no tests
- (arguments '(#:tests? #f))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) ":"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest" "tests")
+ #t)))))
(propagated-inputs
`(("python-h5py" ,python-h5py)
("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
("python-scipy" ,python-scipy)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/linnarsson-lab/loompy")
(synopsis "Work with .loom files for single-cell RNA-seq data")
(description "The loom file format is an efficient format for very large