summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-24 13:24:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-24 13:46:39 +0100
commit513fff4c04cdc157cc8bb165b49a5291f98c8b02 (patch)
tree8289aaf560933b0c416a7867237b25de19fba2fe
parentda94575858971b4f95e241c4f677e0547ae971fe (diff)
downloadpatches-513fff4c04cdc157cc8bb165b49a5291f98c8b02.tar
patches-513fff4c04cdc157cc8bb165b49a5291f98c8b02.tar.gz
gnu: Add texlive-tex-fontinst-base.
* gnu/packages/tex.scm (texlive-tex-fontinst-base): New variable.
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a1caac0522..10fbfab2d3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -543,6 +543,42 @@ converters, will completely supplant the older patterns.")
build fonts using the Metafont system.")
(license license:knuth)))
+(define-public texlive-tex-fontinst-base
+ (package
+ (name "texlive-tex-fontinst-base")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/fontinst/base"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "12gnb8hc45p47pqn31msvi4mpr3wxbbbf2k4xhmshjqykwzlx508"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/fontinst/base")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "https://www.ctan.org/pkg/fontinst")
+ (synopsis "Tools for converting and installing fonts for TeX and LaTeX")
+ (description "This package provides TeX macros for converting Adobe Font
+Metric files to TeX metric and virtual font format. Fontinst helps mainly
+with the number crunching and shovelling parts of font installation. This
+means in practice that it creates a number of files which give the TeX
+metrics (and related information) for a font family that TeX needs to do any
+typesetting in these fonts.")
+ (license license:lppl1.1+)))
+
(define-public texlive-fontname
(package
(name "texlive-fontname")