summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-10-02 16:03:59 -0400
committerLeo Famulari <leo@famulari.name>2018-10-02 16:05:14 -0400
commit3f0f49d70877df6c829b443830de99e0e1e1f6bc (patch)
tree962afaa52b9adfe3b12e4378d68582ee23cc3c77
parentd8d8844ec12c017480e83cd541e98b55e18a17f4 (diff)
downloadpatches-3f0f49d70877df6c829b443830de99e0e1e1f6bc.tar
patches-3f0f49d70877df6c829b443830de99e0e1e1f6bc.tar.gz
gnu: Add poretools.
* gnu/packages/bioinformatics.scm (poretools): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b84498d042..172832d148 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13899,3 +13899,42 @@ adapters, even at low sequence identity. Porechop also supports demultiplexing
of Nanopore reads that were barcoded with the Native Barcoding Kit, PCR
Barcoding Kit or Rapid Barcoding Kit.")
(license license:gpl3+))))
+
+(define-public poretools
+ ;; The latest release was in 2016 and the latest commit is from 2017
+ ;; the recommended way to install is to clone the git repository
+ ;; https://poretools.readthedocs.io/en/latest/content/installation.html
+ (let ((commit "e426b1f09e86ac259a00c261c79df91510777407")
+ (revision "1"))
+ (package
+ (name "poretools")
+ (version (git-version "0.6.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arq5x/poretools.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bglj833wxpp3cq430p1d3xp085ls221js2y90w7ir2x5ay8l7am"))))
+ (build-system python-build-system)
+ ;; requires python >=2.7, <3.0, and the same for python dependencies
+ (arguments `(#:python ,python-2))
+ (inputs
+ `(("hdf5" ,hdf5)))
+ (propagated-inputs
+ `(("python-dateutil" ,python2-dateutil)
+ ("python-h5py" ,python2-h5py)
+ ("python-matplotlib" ,python2-matplotlib)
+ ("python-pandas" ,python2-pandas)
+ ("python-seaborn" ,python2-seaborn)))
+ (home-page "https://poretools.readthedocs.io")
+ (synopsis "Toolkit for working with nanopore sequencing data")
+ (description
+ "The MinION from Oxford Nanopore Technologies is a nanopore sequencer.
+This @code{poretools} package is a flexible toolkit for exploring datasets
+generated by nanopore sequencing devices for the purposes of quality control and
+downstream analysis. Poretools operates directly on the native FAST5, a variant
+of the Hierarchical Data Format (HDF5) standard.")
+ (license license:expat))))