summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-10-02 16:16:45 -0400
committerLeo Famulari <leo@famulari.name>2018-10-02 16:17:00 -0400
commit1ddb2b5c1ca1e18924cbb969c974a0e8d8e54010 (patch)
treef9b93c964365507aa6f4827012f8dd515e3ffa6d
parent3f0f49d70877df6c829b443830de99e0e1e1f6bc (diff)
downloadpatches-1ddb2b5c1ca1e18924cbb969c974a0e8d8e54010.tar
patches-1ddb2b5c1ca1e18924cbb969c974a0e8d8e54010.tar.gz
gnu: Add r-absim.
* gnu/packages/cran.scm (r-absim): New variable.
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b567fdc0ce..4da1664c67 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6131,3 +6131,31 @@ that are part of an activity bout, and find the maximum 10-minute average count
value. The functions are generally very flexible, allowing for a variety of
algorithms to be implemented.")
(license license:gpl3)))
+
+(define-public r-absim
+ (package
+ (name "r-absim")
+ (version "0.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "AbSim" version))
+ (sha256
+ (base32 "16ddjk8b6xw80ch4jis1y751i9561wdxh0gifbf15qiz3vjckq8m"))))
+ (properties `((upstream-name . "AbSim")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ape" ,r-ape)
+ ("r-powerlaw" ,r-powerlaw)))
+ (home-page "https://cran.r-project.org/web/packages/AbSim/")
+ (synopsis "Time resolved simulations of antibody repertoires")
+ (description
+ "This package provides simulation methods for the evolution of antibody repertoires.
+ The heavy and light chain variable region of both human and C57BL/6 mice can
+be simulated in a time-dependent fashion. Both single lineages using one set of
+V-, D-, and J-genes or full repertoires can be simulated. The algorithm begins
+with an initial V-D-J recombination event, starting the first phylogenetic tree.
+ Upon completion, the main loop of the algorithm begins, with each iteration
+representing one simulated time step. Various mutation events are possible at
+each time step, contributing to a diverse final repertoire.")
+ (license license:gpl2)))