summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-06-27 22:03:33 -0400
committerMark H Weaver <mhw@netris.org>2018-11-14 23:44:12 -0500
commit29594404a154b35431609d5f72154c2b69c11dff (patch)
tree756cb5c71657e9490b3baf5af7f393abfddff0f8
parentee527187a651210522ebf0c930cb22077b8d37cc (diff)
downloadpatches-29594404a154b35431609d5f72154c2b69c11dff.tar
patches-29594404a154b35431609d5f72154c2b69c11dff.tar.gz
gnu: check: Return #t from all phases.
* gnu/packages/check.scm (cmdtest, python-pytest-cov, python-fixtures) (python-pytest-localserver, python-pytest-flakes) (python2-coverage-test-runner, python-pylint, python-behave-web-api): Return #t from all phases, and use invoke where appropriate.
-rw-r--r--gnu/packages/check.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 02c1d52740..96144995c1 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -250,7 +250,7 @@ a multi-paradigm automated test framework for C++ and Objective-C.")
;; the build environment. Hence assuming-failure test fails.
(delete-file "yarn.tests/assuming-failure.script")
(delete-file "yarn.tests/assuming-failure.stdout")
- (zero? (system* "python" "setup.py" "check")))))))
+ (invoke "python" "setup.py" "check"))))))
(native-inputs
`(("python2-coverage-test-runner" ,python2-coverage-test-runner)))
(propagated-inputs
@@ -715,8 +715,8 @@ and many external plugins.")
;; options taken from tox.ini
;; TODO: make "--restructuredtext" tests pass. They currently fail
;; with "Duplicate implicit target name"
- (zero? (system* "python" "./setup.py" "check"
- "--strict" "--metadata")))))))
+ (invoke "python" "./setup.py" "check"
+ "--strict" "--metadata"))))))
(propagated-inputs
`(("python-coverage" ,python-coverage)
("python-pytest" ,python-pytest)))
@@ -1100,8 +1100,8 @@ python-fixtures package instead.")
(modify-phases %standard-phases
(replace 'check
(lambda _
- (zero? (system* "python" "-m" "testtools.run"
- "fixtures.test_suite")))))))
+ (invoke "python" "-m" "testtools.run"
+ "fixtures.test_suite"))))))
(propagated-inputs
;; Fixtures uses pbr at runtime to check versions, etc.
`(("python-pbr" ,python-pbr)
@@ -1353,8 +1353,8 @@ the last py.test invocation.")
`(#:phases (modify-phases %standard-phases
(replace 'check
(lambda _
- (zero? (system* "py.test" "--genscript=runtests.py"))
- (zero? (system* "py.test")))))))
+ (invoke "py.test" "--genscript=runtests.py")
+ (invoke "py.test"))))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-requests" ,python-requests)
@@ -1523,7 +1523,7 @@ failures.")
;; It's easier to run tests after install.
;; Make installed package available for running the tests
(add-installed-pythonpath inputs outputs)
- (zero? (system* "py.test" "-vv")))))))
+ (invoke "py.test" "-vv"))))))
(native-inputs
`(("python-coverage" ,python-coverage)
("python-pytest" ,python-pytest)
@@ -1560,7 +1560,7 @@ failures.")
(modify-phases %standard-phases
(replace 'check
(lambda _
- (zero? (system* "./testrun")))))))
+ (invoke "./testrun"))))))
(propagated-inputs
`(("python2-coverage" ,python2-coverage)))
(home-page "https://liw.fi/coverage-test-runner/")
@@ -1606,9 +1606,9 @@ statements in the module it tests.")
(string-append (getenv "PYTHONPATH") ":" work))
(copy-recursively "." work)
(with-directory-excursion "/tmp"
- (zero? (system* "python" "-m" "unittest" "discover"
- "-s" (string-append work "/pylint/test")
- "-p" "*test_*.py")))))))))
+ (invoke "python" "-m" "unittest" "discover"
+ "-s" (string-append work "/pylint/test")
+ "-p" "*test_*.py"))))))))
(home-page "https://github.com/PyCQA/pylint")
(synopsis "Python source code analyzer which looks for coding standard
errors")
@@ -1841,7 +1841,8 @@ tests written in a natural language style, backed up by Python code.")
(lambda _
(substitute* "setup.py"
(("'wheel'") "") ; We don't use it.
- (("'ordereddict==1.1'") ""))))))) ; Python >= 2.7 has it built-in.
+ (("'ordereddict==1.1'") "")) ; Python >= 2.7 has it built-in.
+ #t)))))
(propagated-inputs
`(("behave" ,behave)
("python-requests" ,python-requests)))