summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2020-05-14 08:12:07 +0200
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2020-05-14 10:40:30 +0200
commitf6ec9f9d39eeab1eb5432272d47f87f70e95a890 (patch)
tree4bbf75ecc7a06a4d41f11786ee6e7a51a5db5ea8
parent99f2c9347053b7be78fed96d1b8e4a5cefc05a8c (diff)
downloadpatches-f6ec9f9d39eeab1eb5432272d47f87f70e95a890.tar
patches-f6ec9f9d39eeab1eb5432272d47f87f70e95a890.tar.gz
gnu: gcc-arm-none-eabi@7-2018-q2-update: Fix conflicting GCC headers.base-for-series-3950
This is a follow-up of 7f6d3f395023ff430cf8b7a981d4780698e9d132 and merely a copy-and-paste of Marius Bakke's fix. * gnu/packages/embedded.scm (gcc-arm-none-eabi-7-2018-q2-update)[arguments]: Add phase to remove the default compiler from CPLUS_INCLUDE_PATH. [native-inputs]: Distinguish GCC-5.
-rw-r--r--gnu/packages/embedded.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index b83b67f4a1..6ac1a2d7f3 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -250,7 +251,7 @@ usable on embedded products.")
(origin-patches (package-source gcc-7))
(search-patches "gcc-7-cross-environment-variables.patch")))))
(native-inputs
- `(("gcc" ,gcc-5)
+ `(("gcc@5" ,gcc-5)
("flex" ,flex)
("isl" ,isl-0.18)
,@(alist-delete "isl" (package-native-inputs xgcc))))
@@ -269,7 +270,22 @@ usable on embedded products.")
(lambda _
(substitute* "gcc/genmultilib"
(("#!/bin/sh") (string-append "#!" (which "sh"))))
- #t))))
+ #t))
+ (add-after 'set-paths 'augment-CPLUS_INCLUDE_PATH
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gcc (assoc-ref inputs "gcc")))
+ ;; Remove the default compiler from CPLUS_INCLUDE_PATH to
+ ;; prevent header conflict with the GCC from native-inputs.
+ (setenv "CPLUS_INCLUDE_PATH"
+ (string-join
+ (delete (string-append gcc "/include/c++")
+ (string-split (getenv "CPLUS_INCLUDE_PATH")
+ #\:))
+ ":"))
+ (format #t
+ "environment variable `CPLUS_INCLUDE_PATH' changed to ~a~%"
+ (getenv "CPLUS_INCLUDE_PATH"))
+ #t)))))
((#:configure-flags flags)
;; The configure flags are largely identical to the flags used by the
;; "GCC ARM embedded" project.