summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-20 22:49:34 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-20 23:41:31 +0200
commitf3211ef3868326e3cec5318bc799a2ff6572741b (patch)
treede7a07bbab88ed54184cf08b7fbf2b00a1ef222f
parentfe1818e26a7ff7e2792cfb5c20a92b443bc6a3a0 (diff)
downloadpatches-f3211ef3868326e3cec5318bc799a2ff6572741b.tar
patches-f3211ef3868326e3cec5318bc799a2ff6572741b.tar.gz
build: Move Hydra recipe to build-aux/hydra.
* hydra.scm: Rename to... * build-aux/hydra/gnu-system.scm: ... this. * Makefile.am (EXTRA_DIST): Adjust accordingly.
-rw-r--r--Makefile.am2
-rw-r--r--build-aux/hydra/gnu-system.scm (renamed from hydra.scm)2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f39e571581..418b63a377 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -127,7 +127,7 @@ EXTRA_DIST = \
ROADMAP \
TODO \
.dir-locals.el \
- hydra.scm \
+ build-aux/hydra/gnu-system.scm \
build-aux/download.scm \
build-aux/sync-synopses.scm \
srfi/srfi-64.scm \
diff --git a/hydra.scm b/build-aux/hydra/gnu-system.scm
index c4b6dba924..f03c201223 100644
--- a/hydra.scm
+++ b/build-aux/hydra/gnu-system.scm
@@ -31,7 +31,7 @@
(and=> (assoc-ref (current-source-location) 'filename)
(lambda (file)
- (let ((dir (dirname file)))
+ (let ((dir (string-append (dirname file) "/../..")))
(format (current-error-port) "prepending ~s to the load path~%"
dir)
(set! %load-path (cons dir %load-path))))))