summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-01-03 15:36:00 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-03 20:45:42 +0100
commit6f0c2c95d4c5f5590540acdf108037246d481678 (patch)
tree6a14158559de2f99dd077cccba8c1ed5e54346f3
parentf4448e43b4ce907dd6dfd762ab441570406e7b34 (diff)
downloadpatches-6f0c2c95d4c5f5590540acdf108037246d481678.tar
patches-6f0c2c95d4c5f5590540acdf108037246d481678.tar.gz
gnu: Add external-program.
* gnu/packages/lisp-xyz.scm (sbcl-external-program, cl-external-program, ecl-external-program): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b1e4f593e4..c95d4704f3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -7824,3 +7824,39 @@ from/to strings, streams and files.")
(define-public ecl-cl-csv
(sbcl-package->ecl-package sbcl-cl-csv))
+
+(define-public sbcl-external-program
+ (let ((commit "5888b8f1fd3953feeeacecbba4384ddda584a749")
+ (revision "1"))
+ (package
+ (name "sbcl-external-program")
+ (version (git-version "0.0.6" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sellout/external-program.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vww1x3yilb3bjwg6k184vaj4vxyxw4vralhnlm6lk4xac67kc9z"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("trivial-features" ,sbcl-trivial-features)))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (synopsis "Common Lisp library for running external programs")
+ (description
+ "EXTERNAL-PROGRAM enables running programs outside the Lisp
+process. It is an attempt to make the RUN-PROGRAM functionality in
+implementations like SBCL and CCL as portable as possible without
+sacrificing much in the way of power.")
+ (home-page "https://github.com/sellout/external-program")
+ (license license:llgpl))))
+
+(define-public cl-external-program
+ (sbcl-package->cl-source-package sbcl-external-program))
+
+(define-public ecl-external-program
+ (sbcl-package->ecl-package sbcl-external-program))