summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-04-25 20:46:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-05-06 11:52:07 +0200
commit32cf42c1eb4aa35750b6fccc935b9e1228d64cf6 (patch)
tree0b5023c9fedc6294a132301a7639d75d518c5802
parentd73f79099b9c756bc279f8f267b4a055fd3f668b (diff)
downloadpatches-32cf42c1eb4aa35750b6fccc935b9e1228d64cf6.tar
patches-32cf42c1eb4aa35750b6fccc935b9e1228d64cf6.tar.gz
gnu: Add IR.
* gnu/packages/audio.scm (ir): New variable.
-rw-r--r--gnu/packages/audio.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 29547a3991..17a64a050f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -488,6 +488,46 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
;; GPLv2+ with exception for compositions using these patches.
(license license:gpl2+)))
+(define-public ir
+ (package
+ (name "ir")
+ (version "1.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://factorial.hu/system/files/ir.lv2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1jh2z01l9m4ar7yz0n911df07dygc7n4cl59p7qdjbh0nvkm747g"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no "check" target
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ ;; no configure script
+ (alist-delete 'configure %standard-phases)))
+ (inputs
+ `(("libsndfile" ,libsndfile)
+ ("libsamplerate" ,libsamplerate)
+ ("lv2" ,lv2)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+-2)
+ ("zita-convolver" ,zita-convolver)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LV2_PATH")
+ (files '("lib/lv2")))))
+ (home-page "http://factorial.hu/plugins/lv2/ir")
+ (synopsis "LV2 convolution reverb")
+ (description
+ "IR is a low-latency, real-time, high performance signal convolver
+especially for creating reverb effects. It supports impulse responses with 1,
+2 or 4 channels, in any soundfile format supported by libsndfile.")
+ (license license:gpl2+)))
+
(define-public jack-1
(package
(name "jack")