summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-20 01:33:29 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-20 01:38:56 +0100
commit0f0995521393b9ec1733de3475bf74c89732e556 (patch)
tree6efed86d019eed85485411410f7befec91015a5f
parent5d4fd2671aaadc5b0b7e0c331fa5e2a1d7e5c4d8 (diff)
downloadpatches-0f0995521393b9ec1733de3475bf74c89732e556.tar
patches-0f0995521393b9ec1733de3475bf74c89732e556.tar.gz
distro: Update bootstrap binaries.
Use bootstrap binaries that were generated with the `make-bootstrap' changes introduced in previous commit. * Makefile.am (nodist_bootstrap_x86_64_linux_DATA, nodist_bootstrap_i686_linux_DATA): Change Guile tarball name. (distro/packages/bootstrap/x86_64-linux/guile-2.0.7.tar.xz, distro/packages/bootstrap/i686-linux/guile-2.0.7.tar.xz): New targets. (distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz, distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz): Remove. * build-aux/download.scm (file-name->uri): Use "20121219" directory. * distro/packages/bootstrap.scm (%bootstrap-guile): Update file name. (%bootstrap-coreutils&co, %bootstrap-binutils, %bootstrap-glibc, %bootstrap-gcc): Update directory name and hashes.
-rw-r--r--Makefile.am12
-rw-r--r--build-aux/download.scm2
-rw-r--r--distro/packages/bootstrap.scm24
3 files changed, 19 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index f256e47995..0f58d09d8b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -142,9 +142,9 @@ dist_bootstrap_i686_linux_DATA = \
# Big bootstrap binaries are not included in the tarball. Instead, they
# are downloaded.
nodist_bootstrap_x86_64_linux_DATA = \
- distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz
+ distro/packages/bootstrap/x86_64-linux/guile-2.0.7.tar.xz
nodist_bootstrap_i686_linux_DATA = \
- distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz
+ distro/packages/bootstrap/i686-linux/guile-2.0.7.tar.xz
# Those files must remain executable, so they remain executable once
# imported into the store.
@@ -161,12 +161,12 @@ DOWNLOAD_FILE = \
$(GUILE) --no-auto-compile -L "$(top_builddir)" -L "$(top_srcdir)" \
"$(top_srcdir)/build-aux/download.scm"
-distro/packages/bootstrap/x86_64-linux/guile-bootstrap-2.0.6.tar.xz:
+distro/packages/bootstrap/x86_64-linux/guile-2.0.7.tar.xz:
$(MKDIR_P) `dirname "$@"`
- $(DOWNLOAD_FILE) "$@" "0467a82cbe4136f60a79eb4176011bf88cf28ea19c9ad9defa365811ff8e11cf"
-distro/packages/bootstrap/i686-linux/guile-bootstrap-2.0.6.tar.xz:
+ $(DOWNLOAD_FILE) "$@" "953fbcc8db6e310626be79b67319cf4141dc23b296447952a99d95425b3a4dc1"
+distro/packages/bootstrap/i686-linux/guile-2.0.7.tar.xz:
$(MKDIR_P) `dirname "$@"`
- $(DOWNLOAD_FILE) "$@" "93b537766dfab3ad287143523751e3ec02dd32d3ccaf88ad2d31c63158f342ee"
+ $(DOWNLOAD_FILE) "$@" "45d1f9bfb9e4531a8f1c5a105f7ab094cd481b8a179ccc63cbabb73ce6b8437f"
nobase_nodist_guilemodule_DATA = $(GOBJECTS) guix/config.scm
diff --git a/build-aux/download.scm b/build-aux/download.scm
index 4c1a1a6e5d..f5d23f2701 100644
--- a/build-aux/download.scm
+++ b/build-aux/download.scm
@@ -35,7 +35,7 @@
(match (string-tokenize file (char-set-complement (char-set #\/)))
((_ ... system basename)
(string->uri (string-append %url-base "/" system
- "/20121115/" basename)))))
+ "/20121219/" basename)))))
(match (command-line)
((_ file expected-hash)
diff --git a/distro/packages/bootstrap.scm b/distro/packages/bootstrap.scm
index 6dc9c3d965..222f087372 100644
--- a/distro/packages/bootstrap.scm
+++ b/distro/packages/bootstrap.scm
@@ -167,7 +167,7 @@ check whether everything is alright."
(xz (->store "xz"))
(mkdir (->store "mkdir"))
(bash (->store "bash"))
- (guile (->store "guile-bootstrap-2.0.6.tar.xz"))
+ (guile (->store "guile-2.0.7.tar.xz"))
(builder
(add-text-to-store store
"build-bootstrap-guile.sh"
@@ -205,15 +205,15 @@ $out/bin/guile --version~%"
(method url-fetch)
(uri (string-append
%bootstrap-base-url "/"
- system "/20121115/static-binaries.tar.xz"))
+ system "/20121219/static-binaries.tar.xz"))
(sha256
(match system
("x86_64-linux"
(base32
- "0azisn8l2b3cvgni9k0ahzsxs5cxrj0hmf38zgpq3k6pggk3zbfm"))
+ "1vvdr1hfbjxlincpgfwhz9l4mbrjf502bv5nivapk5b2d3xxfyvv"))
("i686-linux"
(base32
- "16v60frbh0naccanwxcxz0z3444dd8salbg8p7cp7vwz8245nhfk"))))))
+ "18ky02ifa0w5afyil04fh5whlsqdw0h8kn2fkibfhwfsm5q9d5fx"))))))
"true" ; the program to test
"Bootstrap binaries of Coreutils, Awk, etc."))
@@ -224,7 +224,7 @@ $out/bin/guile --version~%"
(method url-fetch)
(uri (string-append
%bootstrap-base-url "/"
- system "/20121115/binutils-2.22.tar.xz"))
+ system "/20121219/binutils-2.22.tar.xz"))
(sha256
(match system
("x86_64-linux"
@@ -232,7 +232,7 @@ $out/bin/guile --version~%"
"0ms6i035v40n7mhi91n4b8ivwv2qni3mcd5dj9sj9qmvgqb50r84"))
("i686-linux"
(base32
- "193x62ach4l4x16rbzglrqa1d0a825z2as6czdiv9xjiizmcr0ad"))))))
+ "16yr3jxqjvd979vvpikfn4rl9fqrbcs5viwd2r8xzf5bakc2mq9p"))))))
"ld" ; the program to test
"Bootstrap binaries of the GNU Binutils"))
@@ -277,15 +277,15 @@ $out/bin/guile --version~%"
(origin
(method url-fetch)
(uri (string-append %bootstrap-base-url "/" system
- "/20121115/glibc-2.16.0.tar.xz"))
+ "/20121219/glibc-2.16.0.tar.xz"))
(sha256
(match system
("x86_64-linux"
(base32
- "1cz587p3scrrx0zgqnmp4nnfj0vvf01zdqdgkz445dnbfh64nl0v"))
+ "1mqpb2sxfa5whdq0adyrgg7j3ci5v4d42wna8hg4j3dbcr5b2vpi"))
("i686-linux"
(base32
- "0vzybz1577vflm0p0zg1slqj32carj5102b45k7iskkj46viy14z"))))))))))
+ "03wb29srsdswc775ppzwllys0dqyy235shm1n64jl6njw4l7c5x6"))))))))))
(synopsis "Bootstrap binaries and headers of the GNU C Library")
(description #f)
(home-page #f)))
@@ -348,15 +348,15 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
(origin
(method url-fetch)
(uri (string-append %bootstrap-base-url "/" system
- "/20121115/gcc-4.7.2.tar.xz"))
+ "/20121219/gcc-4.7.2.tar.xz"))
(sha256
(match system
("x86_64-linux"
(base32
- "0fg65i2qcym8ls5ig3g1cc9ida5cxwwsd6zi95xi1d8dnfrja4zz"))
+ "1k374q9v1bph8605sirzmaxnawbddahpgq8d99x1527gj5n2xws1"))
("i686-linux"
(base32
- "01hlz98qmc8yhqrxqajpg5kbkhpvqq6wjnbfvplys32n895avzxg"))))))))))
+ "040jkqkh0qyva5z6gy4d95khhhvsw4vp8x3l818gpi6hfknwb9l8"))))))))))
(synopsis "Bootstrap binaries of the GNU Compiler Collection")
(description #f)
(home-page #f)))