summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-01-20 00:37:05 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-20 00:45:30 +0100
commiteb3e41c92c3b2a256e5ff94f2d4557eeaa9d71d8 (patch)
tree7857f00d465851ebf16f09c7abc88a36e26964a3
parent20fe7271051403ee431c2fd72ff76d9c44acdb6c (diff)
downloadpatches-eb3e41c92c3b2a256e5ff94f2d4557eeaa9d71d8.tar
patches-eb3e41c92c3b2a256e5ff94f2d4557eeaa9d71d8.tar.gz
gnu: Add Motion.
* gnu/packages/video.scm (motion): New variable.
-rw-r--r--gnu/packages/video.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 930c0eb916..2db16b179a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2672,3 +2672,47 @@ It counts more than 100 plugins.")
;; src/filter/ndvi/ndvi.cpp
;; src/filter/facedetect/facedetect.cpp
license:lgpl2.1+))))
+
+(define-public motion
+ (package
+ (name "motion")
+ (version "4.1.1")
+ (home-page "https://motion-project.github.io/")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Motion-Project/motion/archive/"
+ "release-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1qm4i8zrqafl60sv2frhixvkd0wh0r5jfcrj5i6gha7yplsvjx10"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,(autoconf-wrapper))
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libjpeg" ,libjpeg)
+ ("ffmpeg" ,ffmpeg)
+ ("sqlite" ,sqlite)))
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (patch-shebang "version.sh")
+ (invoke "autoreconf" "-vfi"))))
+ #:configure-flags '("--sysconfdir=/etc")
+ #:make-flags (list (string-append "sysconfdir="
+ (assoc-ref %outputs "out")
+ "/etc"))
+
+ #:tests? #f)) ;no 'check' target
+ (synopsis "Detect motion from video signals")
+ (description
+ "Motion is a program that monitors the video signal from one or more
+cameras and is able to detect if a significant part of the picture has
+changed. Or in other words, it can detect motion.")
+
+ ;; Some files say "version 2" and others "version 2 or later".
+ (license license:gpl2)))