summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-11-19 19:12:33 +0800
committer宋文武 <iyzsong@gmail.com>2016-11-19 19:19:16 +0800
commitae1e2133b9cb776f557ffcf2cb61888618c1d509 (patch)
tree029c8834e963ba9692681c172dced7adb8e0b103
parentcfcef2c2ac9d87271c411c0515a928bdac312484 (diff)
downloadpatches-ae1e2133b9cb776f557ffcf2cb61888618c1d509.tar
patches-ae1e2133b9cb776f557ffcf2cb61888618c1d509.tar.gz
gnu: opensmtpd: Correct CA certificates file path.
* gnu/packages/mail.scm (opensmtpd)[arguments]: Pass '--with-path-CAfile=/etc/ssl/certs/ca-certificates.crt' to #:configure-flags.
-rw-r--r--gnu/packages/mail.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6fcb548e61..a365e37f9b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1625,10 +1625,12 @@ transfer protocols.")
`(("bison" ,bison)
("groff" ,groff)))
(arguments
- `(#:configure-flags (list "--with-table-db" "--localstatedir=/var"
- "--with-user-smtpd=smtpd" "--with-user-queue=smtpq"
- "--with-group-queue=smtpq"
- "--with-path-socket=/var/run")
+ `(#:configure-flags
+ (list "--with-table-db" "--localstatedir=/var"
+ "--with-user-smtpd=smtpd" "--with-user-queue=smtpq"
+ "--with-group-queue=smtpq"
+ "--with-path-socket=/var/run"
+ "--with-path-CAfile=/etc/ssl/certs/ca-certificates.crt")
#:phases
(modify-phases %standard-phases
;; OpenSMTPD provides a single utility smtpctl to control the daemon and