summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-09-19 12:18:19 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-09-19 15:44:20 +1000
commit7bba95b769e25cd9d1854029a1557d4f97c84235 (patch)
treefdecc0c0c0c88aa6c1dc7e93131bdf1257bd26ca
parent4b1a15282677b15a5949ec144567529f70260203 (diff)
downloadpatches-7bba95b769e25cd9d1854029a1557d4f97c84235.tar
patches-7bba95b769e25cd9d1854029a1557d4f97c84235.tar.gz
gnu: seqmagick: Use BioPython 1.66.
* gnu/packages/bioinformatics.scm (seqmagick)[inputs]: Use python2-biopython-1.66 instead of python2-biopython.
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5effc80a4c..21fc96e033 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4593,7 +4593,11 @@ bioinformatics file formats, sequence alignment, and more.")
;; https://github.com/fhcrc/seqmagick/issues/55
(replace 'check (lambda _ (zero? (system* "nosetests")))))))
(inputs
- `(("python-biopython" ,python2-biopython)))
+ ;; biopython-1.66 is required due to
+ ;; https://github.com/fhcrc/seqmagick/issues/59
+ ;; When that issue is resolved the 'python2-biopython-1.66' package
+ ;; should be removed.
+ `(("python-biopython" ,python2-biopython-1.66)))
(native-inputs
`(("python-setuptools" ,python2-setuptools)
("python-nose" ,python2-nose)))