summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-11 21:25:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-18 23:19:44 +0300
commit44547e51530e93ac6215bd32f2ee9e00b426544d (patch)
treee0ed7780eafa0cd2bcef76d7f8c7a664dc6d098b
parent5cb2fe446bf3357e3320bfd5c00ccfac131cd4fd (diff)
downloadpatches-44547e51530e93ac6215bd32f2ee9e00b426544d.tar
patches-44547e51530e93ac6215bd32f2ee9e00b426544d.tar.gz
gnu: Add python-pytest-mock.
* gnu/packages/python.scm (python-pytest-mock): New variable.
-rw-r--r--gnu/packages/python.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 86d099a291..590a0566e5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1684,6 +1684,45 @@ supports coverage of subprocesses.")
(define-public python2-pytest-runner
(package-with-python2 python-pytest-runner))
+(define-public python-pytest-mock
+ (package
+ (name "python-pytest-mock")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-mock" version ".zip"))
+ (sha256
+ (base32
+ "03zxar5drzm7ksqyrwypjaza3cri6wqvpr6iam92djvg6znp32gp"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (inputs
+ `(("python-py" ,python-py)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/pytest-dev/pytest-mock/")
+ (synopsis "Thin-wrapper around the mock package for easier use with py.test")
+ (description
+ "This plugin installs a @code{mocker} fixture which is a thin-wrapper
+around the patching API provided by the @code{mock} package, but with the
+benefit of not having to worry about undoing patches at the end of a test.
+The mocker fixture has the same API as @code{mock.patch}, supporting the
+same arguments.")
+ (properties `((python2-variant . ,(delay python2-pytest-mock))))
+ (license license:expat)))
+
+(define-public python2-pytest-mock
+ (let ((base (package-with-python2
+ (strip-python2-variant python-pytest-mock))))
+ (package (inherit base)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base)))
+ (inputs
+ `(("python2-mock" ,python2-mock)
+ ,@(package-inputs base))))))
+
(define-public python-pytest-xdist
(package
(name "python-pytest-xdist")