summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-11 21:34:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-18 23:19:45 +0300
commit12f839fdf685e68dda8f38af1bbb192fa4199d25 (patch)
tree050f651d7feb789f5fedd39103f8dbc16548b158
parent257023978aca29d381d63d00e4a6cc1d1bd2857a (diff)
downloadpatches-12f839fdf685e68dda8f38af1bbb192fa4199d25.tar
patches-12f839fdf685e68dda8f38af1bbb192fa4199d25.tar.gz
gnu: Add python-cov-core.
* gnu/packages/python.scm (python-cov-core): New variable.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index edc99dc0d4..7536259c64 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2104,6 +2104,34 @@ executed.")
(define-public python2-coverage
(package-with-python2 python-coverage))
+(define-public python-cov-core
+ (package
+ (name "python-cov-core")
+ (version "1.15.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cov-core" version))
+ (sha256
+ (base32
+ "0k3np9ymh06yv1ib96sb6wfsxjkqhmik8qfsn119vnhga9ywc52a"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-coverage" ,python-coverage)))
+ (home-page "https://github.com/schlamar/cov-core")
+ (synopsis "plugin core for use by pytest-cov, nose-cov and nose2-cov")
+ (description
+ "This is a library package for use by pytest-cov, nose-cov and nose2-cov.
+It is useful for developing coverage plugins for these testing frameworks.")
+ (license license:expat)))
+
+(define-public python2-cov-core
+ (let ((cov-core (package-with-python2 python-cov-core)))
+ (package (inherit cov-core)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs cov-core))))))
+
(define-public python-discover
(package
(name "python-discover")