summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-06 22:39:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-07 08:15:44 +0100
commit15ca1959793b5ed9ae8fb525493edf9bd3caf2b8 (patch)
tree7dbe401f1f8f430fc5e694137eb6b9e9f2b0ff27
parent34b9675449fb5f2e027c91e4d322f4e74bf1e1e1 (diff)
downloadpatches-15ca1959793b5ed9ae8fb525493edf9bd3caf2b8.tar
patches-15ca1959793b5ed9ae8fb525493edf9bd3caf2b8.tar.gz
gnu: r-mzr: Remove bundled copy of boost.
* gnu/packages/bioinformatics.scm (r-mzr)[source]: Remove boost source. [arguments]: Add build phase "use-system-boost" to link with our boost package and avoid building the bundled sources.
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2ad5f953e1..115af50eb4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8899,9 +8899,26 @@ proteomics packages.")
(uri (bioconductor-uri "mzR" version))
(sha256
(base32
- "1x3gp30sfxz2v3k3swih9kff9b2rvk7hzhnlkp6ywlnn2wgb0q8c"))))
+ "1x3gp30sfxz2v3k3swih9kff9b2rvk7hzhnlkp6ywlnn2wgb0q8c"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "src/boost")
+ #t))))
(properties `((upstream-name . "mzR")))
(build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'use-system-boost
+ (lambda _
+ (substitute* "src/Makevars"
+ (("\\./boost/libs.*") "")
+ (("ARCH_OBJS=" line)
+ (string-append line
+ "\nARCH_LIBS=-lboost_system -lboost_regex \
+-lboost_iostreams -lboost_thread -lboost_filesystem -lboost_chrono\n")))
+ #t)))))
(inputs
`(("boost" ,boost) ; use this instead of the bundled boost sources
("netcdf" ,netcdf)))