summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-11-13 22:50:57 +0800
committerLudovic Courtès <ludo@gnu.org>2014-11-14 22:56:47 +0100
commit13d18626327d94c975943a1481d04d478db20c70 (patch)
treece42b1201d2831656fb3a7d40d9b21979c0d168f
parenteb59595ccdd1d58730e3d24da41ecacb27813666 (diff)
downloadpatches-13d18626327d94c975943a1481d04d478db20c70.tar
patches-13d18626327d94c975943a1481d04d478db20c70.tar.gz
gnu: Add Tiled.
* gnu/packages/games.scm (tiled): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/games.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index dee39dd241..a05d389e82 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -23,7 +23,8 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages games)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses)
+ #:hide (zlib))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (gnu packages)
@@ -49,6 +50,8 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages bash)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages compression)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial))
@@ -498,3 +501,37 @@ tutorials for the standard QWERTY layout, there are also tutorials for the
alternative layouts Dvorak and Colemak, as well as for the numpad. Tutorials
are primarily in English, however some in other languages are provided.")
(license gpl3+)))
+
+(define-public tiled
+ (package
+ (name "tiled")
+ (version "0.10.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/bjorn/tiled/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0p4p3lv4nw11fkfvvyjirb93r2x4w2rrc2w650gl2k57k92jpiij"))))
+ (build-system gnu-build-system)
+ (inputs `(("qt" ,qt)
+ ("zlib" ,zlib)))
+ (arguments
+ '(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (system* "qmake"
+ (string-append "PREFIX=" out))))
+ %standard-phases)))
+ (home-page "http://www.mapeditor.org/")
+ (synopsis "Tile map editor")
+ (description
+ "Tiled is a general purpose tile map editor. It is meant to be used for
+editing maps of any tile-based game, be it an RPG, a platformer or a Breakout
+clone.")
+
+ ;; As noted in 'COPYING', part of it is under GPLv2+, while the rest is
+ ;; under BSD-2.
+ (license gpl2+)))