summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-26 03:01:48 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-26 03:01:48 +0100
commitb8509387d1e303b24204213c09fe82f35899ebff (patch)
tree5db662d0658dc1d201547b99573a35d01dd6894b
parent557f8f212e9bfc28ce689a2ccbcc91c8dafe01b2 (diff)
downloadpatches-b8509387d1e303b24204213c09fe82f35899ebff.tar
patches-b8509387d1e303b24204213c09fe82f35899ebff.tar.gz
gnu: python-pathpy: Update to 11.0.
* gnu/packages/python.scm (python-pathpy): Update to 11.0. [source](uri): Use PYPI-URI. [outputs]: Remove field. [arguments]: Set #:tests? #f. Remove #:phases.
-rw-r--r--gnu/packages/python.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2129cbec07..1b5e3836d9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4270,15 +4270,14 @@ them as the version argument or in a SCM managed file.")
(define-public python-pathpy
(package
(name "python-pathpy")
- (version "8.1.1")
+ (version "11.0")
(source
(origin
(method url-fetch)
- (uri (string-append "https://pypi.python.org/packages/source/p/"
- "path.py/path.py-" version ".tar.gz"))
+ (uri (pypi-uri "path.py" version))
(sha256
- (base32 "1p8s1l2vfkqhqxdhqlj0g1jjw4f1as2frr35sjcpjjpd5a89y41f"))))
- (outputs '("out" "doc"))
+ (base32 "12s84maimiz61980q065rjgi8ang6xw2wwm64m0lmfks51dlw4qn"))))
+ ;; (outputs '("out" "doc"))
(build-system python-build-system)
(propagated-inputs
`(("python-appdirs" ,python-appdirs)))
@@ -4289,22 +4288,24 @@ them as the version argument or in a SCM managed file.")
("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'build 'build-doc
- (lambda _
- (setenv "LANG" "en_US.UTF-8")
- (zero? (system* "python" "setup.py" "build_sphinx"))))
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((data (string-append (assoc-ref outputs "doc") "/share"))
- (doc (string-append data "/doc/" ,name "-" ,version))
- (html (string-append doc "/html")))
- (mkdir-p html)
- (for-each (lambda (file)
- (copy-file file (string-append doc "/" file)))
- '("README.rst" "CHANGES.rst"))
- (copy-recursively "build/sphinx/html" html)))))))
+ ;; FIXME: Documentation and tests require "jaraco.packaging".
+ `(#:tests? #f))
+ ;; #:phases
+ ;; (modify-phases %standard-phases
+ ;; (add-after 'build 'build-doc
+ ;; (lambda _
+ ;; (setenv "LANG" "en_US.UTF-8")
+ ;; (zero? (system* "python" "setup.py" "build_sphinx"))))
+ ;; (add-after 'install 'install-doc
+ ;; (lambda* (#:key outputs #:allow-other-keys)
+ ;; (let* ((data (string-append (assoc-ref outputs "doc") "/share"))
+ ;; (doc (string-append data "/doc/" ,name "-" ,version))
+ ;; (html (string-append doc "/html")))
+ ;; (mkdir-p html)
+ ;; (for-each (lambda (file)
+ ;; (copy-file file (string-append doc "/" file)))
+ ;; '("README.rst" "CHANGES.rst"))
+ ;; (copy-recursively "build/sphinx/html" html)))))))
(home-page "https://github.com/jaraco/path.py")
(synopsis "Python module wrapper for built-in os.path")
(description