summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-03-11 11:55:28 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-11 11:55:28 +1000
commite08ad76658f0bd1b9880c2388ae004ff0daca1cb (patch)
treea17728b59d045dfcbba6846f14aeabeb7e11aaa5
parent7711f614502948274ceaf1c7547d8abe40b81c9b (diff)
downloadpatches-e08ad76658f0bd1b9880c2388ae004ff0daca1cb.tar
patches-e08ad76658f0bd1b9880c2388ae004ff0daca1cb.tar.gz
gnu: Add r-fnn.
* gnu/packages/statistics.scm (r-fnn): New variable. Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 6ab64a5c8f..ff2aab2a83 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4421,3 +4421,24 @@ VGLMs can be loosely thought of as multivariate generalised linear models.")
functions apply. The implementation can easily be added to functions where
showing the progress is useful e.g. bootstrap.")
(license license:gpl2)))
+
+(define-public r-fnn
+ (package
+ (name "r-fnn")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "FNN" version))
+ (sha256
+ (base32
+ "1kncmiaraq1mrykb9fj3fsxswabk3l71fnp1vks0x9aay5xfk8mj"))))
+ (properties `((upstream-name . "FNN")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/FNN")
+ (synopsis "Fast nearest neighbor search algorithms and applications")
+ (description
+ "This package provides cover-tree and kd-tree fast k-nearest neighbor
+search algorithms and related applications including KNN classification,
+regression and information measures.")
+ (license license:gpl2+)))