summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-06-11 21:21:02 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-06-13 19:22:54 -0400
commit32ac717c5f38192b8bf832e2aba4e83e38a201c3 (patch)
treef75ab811f33160002f46a32c712f65ad9bc3e973
parente4a44a6aa5b6dcda39ab8c347d1dc68a4cc7e4f9 (diff)
downloadpatches-32ac717c5f38192b8bf832e2aba4e83e38a201c3.tar
patches-32ac717c5f38192b8bf832e2aba4e83e38a201c3.tar.gz
gnu: Add gnome-shell-extensions.
* gnu/packages/gnome.scm (gnome-shell-extensions): New variable.
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c87c371423..0b80ebb448 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5183,6 +5183,33 @@ alternative user interface themes, changes in window management behavior,
GNOME Shell appearance and extension, etc.")
(license license:gpl3+)))
+(define-public gnome-shell-extensions
+ (package
+ (name "gnome-shell-extensions")
+ (version "3.20.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "18rr55krnqx1nzrzlj6kfzh4n67f3crakmwh28rr95y7cg0jwhxw"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--enable-extensions=all")))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("glib" ,glib)
+ ("glib" ,glib "bin")))
+ (synopsis "Extensions for GNOME Shell")
+ (description "GNOME Shell extensions modify and extend GNOME Shell
+functionality and behavior.")
+ (home-page "https://extensions.gnome.org/")
+ (license license:gpl3+)))
+
(define-public arc-theme
(package
(name "arc-theme")