summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-16 21:38:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-16 21:38:55 +0200
commit9cb2f28c5a737576ec28099d69aa35ff687e7778 (patch)
treead7df4340cd5125f2de436619c947ec679a860be
parent2e7e0cb54770c0b8053b87f5f45303e0b0cda353 (diff)
downloadpatches-9cb2f28c5a737576ec28099d69aa35ff687e7778.tar
patches-9cb2f28c5a737576ec28099d69aa35ff687e7778.tar.gz
gnu: xournalpp: Update to 1.0.18.
* gnu/packages/pdf.scm (xournalpp): Update to 1.0.18.
-rw-r--r--gnu/packages/pdf.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 9d517bbf2f..39e41c7f1b 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -822,7 +822,7 @@ using a stylus.")
(define-public xournalpp
(package
(name "xournalpp")
- (version "1.0.17")
+ (version "1.0.18")
(source
(origin
(method git-fetch)
@@ -831,7 +831,7 @@ using a stylus.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0xw2mcgnm4sa9hrhfgp669lfypw97drxjmz5w8i5whaprpvmkxzw"))))
+ (base32 "0a9ygbmd4dwgck3k8wsrm2grynqa0adb12wwspzmzvpisbadffjy"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DENABLE_CPPUNIT=ON") ;enable tests
@@ -844,11 +844,11 @@ using a stylus.")
(modify-phases %standard-phases
(add-after 'unpack 'fix-permissions-on-po-files
(lambda _
- ;; Always generate translations. A recent upstream patch
- ;; disabled it.
- (substitute* "po/CMakeLists.txt"
- (("gettext_create_translations \\(\"\\$\\{potfile\\}\"\\)")
- "gettext_create_translations (\"${potfile}\" ALL)"))
+ ;; ;; Always generate translations. A recent upstream patch
+ ;; ;; disabled it.
+ ;; (substitute* "po/CMakeLists.txt"
+ ;; (("gettext_create_translations \\(\"\\$\\{potfile\\}\"\\)")
+ ;; "gettext_create_translations (\"${potfile}\" ALL)"))
;; Make sure 'msgmerge' can modify the PO files.
(for-each (lambda (po) (chmod po #o666))
(find-files "." "\\.po$"))
@@ -857,7 +857,6 @@ using a stylus.")
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs
`(("cppunit" ,cppunit)
- ("gcc" ,gcc-8) ;requires gcc 8+
("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
(inputs