summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-04-16 15:08:53 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-04-16 15:08:53 +0200
commit90ec7085793700552359d9d409287528437f0280 (patch)
treec08c6a9bcba22bd8d77be750193a476c3136eee2
parent660912a477d4b9145e0f0b6bc289555842aec3f6 (diff)
downloadpatches-90ec7085793700552359d9d409287528437f0280.tar
patches-90ec7085793700552359d9d409287528437f0280.tar.gz
gnu: Add flwrap.
* gnu/packages/radio.scm (flwrap): New variable.
-rw-r--r--gnu/packages/radio.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 417677ec04..8f1562a176 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -615,3 +615,32 @@ or USB connection.")
(Amateur Multicast Protocol).")
(home-page "http://www.w1hkj.com/")
(license license:gpl3+)))
+
+(define-public flwrap
+ (package
+ (name "flwrap")
+ (version "1.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.w1hkj.com/files/flwrap/flwrap-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0qqivqkkravcg7j45740xfky2q3k7czqpkj6y364qff424q2pppg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("fltk" ,fltk)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxfixes" ,libxfixes)
+ ("libxft" ,libxft)))
+ (synopsis "File encapsulation program")
+ (description
+ "Flwrap is a software utility for amateur radio use. Its purpose is to
+encapsulate both text and binary files in a way that allows them to be
+transmitted over any of several digital modes and verified at the receipt end
+for correctness.")
+ (home-page "http://www.w1hkj.com/")
+ (license license:gpl3+)))