summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-18 23:50:15 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-18 23:53:00 +0100
commit32243bfb57aa5d280b4949954af2df9c93b327e1 (patch)
tree48d9ba658c8d72d842d16071db202e0a07415a53
parent09964b4fc612c55f7a2e519429d318469830c921 (diff)
downloadpatches-32243bfb57aa5d280b4949954af2df9c93b327e1.tar
patches-32243bfb57aa5d280b4949954af2df9c93b327e1.tar.gz
gnu: commencement: Avoid redundant Perl rebuild.
This removes a redundant (yet different) "perl-boot0" node from the early derivation graph. * gnu/packages/commencement.scm (bison-boot1): Move 'native-inputs' field to the final package. Previously PERL-BOOT0 got rebuilt with %BOOT0-INPUTS, leading to a different derivation. (static-bash-for-glibc): Likewise.
-rw-r--r--gnu/packages/commencement.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 578ded215f..7c13ecf598 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -429,14 +429,15 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(current-source-location)
#:guile %bootstrap-guile)))
(bison (package (inherit bison)
- (native-inputs `(("perl" ,perl-boot0)))
(propagated-inputs `(("m4" ,m4)))
(inputs '()) ;remove Flex...
(arguments '(#:tests? #f))))) ;... and thus disable tests
- (package-with-bootstrap-guile
- (package-with-explicit-inputs bison %boot0-inputs
- (current-source-location)
- #:guile %bootstrap-guile))))
+ (package
+ (inherit (package-with-bootstrap-guile
+ (package-with-explicit-inputs bison %boot0-inputs
+ (current-source-location)
+ #:guile %bootstrap-guile)))
+ (native-inputs `(("perl" ,perl-boot0))))))
(define static-bash-for-glibc
;; A statically-linked Bash to be used by GLIBC-FINAL in system(3) & co.
@@ -444,17 +445,18 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
glibc-final-with-bootstrap-bash
(car (assoc-ref %boot1-inputs "bash"))))
(bash (package (inherit static-bash)
- (native-inputs `(("bison" ,bison-boot1)))
(arguments
`(#:guile ,%bootstrap-guile
- ,@(package-arguments static-bash))))))
- (package-with-bootstrap-guile
- (package-with-explicit-inputs bash
- `(("gcc" ,gcc)
- ("libc" ,glibc-final-with-bootstrap-bash)
- ,@(fold alist-delete %boot1-inputs
- '("gcc" "libc")))
- (current-source-location)))))
+ ,@(package-arguments static-bash)))))
+ (inputs `(("gcc" ,gcc)
+ ("libc" ,glibc-final-with-bootstrap-bash)
+ ,@(fold alist-delete %boot1-inputs
+ '("gcc" "libc")))))
+ (package
+ (inherit (package-with-bootstrap-guile
+ (package-with-explicit-inputs bash inputs
+ (current-source-location))))
+ (native-inputs `(("bison" ,bison-boot1))))))
(define gettext-boot0
;; A minimal gettext used during bootstrap.