summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-18 22:17:47 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-18 22:19:07 +0100
commit09964b4fc612c55f7a2e519429d318469830c921 (patch)
tree942412f58ad0ee6d07f5be70676f13f6fe1cf41e
parent009b53fd1ce162dce35249babfd63b26aa7ad580 (diff)
downloadpatches-09964b4fc612c55f7a2e519429d318469830c921.tar
patches-09964b4fc612c55f7a2e519429d318469830c921.tar.gz
gnu: commencement: Add "-boot0" to early packages.
* gnu/packages/commencement.scm (diffutils-boot0)[name]: New field. * gnu/packages/commencement.scm (findutils-boot0, file-boot0, perl-boot0): Change 'name' field to include "-boot0".
-rw-r--r--gnu/packages/commencement.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index eda04325f0..578ded215f 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -92,12 +92,15 @@
,@%bootstrap-inputs)
#:guile %bootstrap-guile)))
(package (inherit p)
+ (name "diffutils-boot0")
(arguments `(#:tests? #f ; the test suite needs diffutils
,@(package-arguments p)))))))
(define findutils-boot0
(package-with-bootstrap-guile
- (package-with-explicit-inputs findutils
+ (package-with-explicit-inputs (package
+ (inherit findutils)
+ (name "findutils-boot0"))
`(("make" ,gnu-make-boot0)
("diffutils" ,diffutils-boot0) ; for tests
,@%bootstrap-inputs)
@@ -106,7 +109,9 @@
(define file-boot0
(package-with-bootstrap-guile
- (package-with-explicit-inputs file
+ (package-with-explicit-inputs (package
+ (inherit file)
+ (name "file-boot0"))
`(("make" ,gnu-make-boot0)
,@%bootstrap-inputs)
(current-source-location)
@@ -262,6 +267,7 @@
(define perl-boot0
(let ((perl (package
(inherit perl)
+ (name "perl-boot0")
(arguments
(substitute-keyword-arguments (package-arguments perl)
((#:phases phases)