summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-15 23:28:29 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-15 23:28:29 +0100
commit0573bb5e61ed0351d4e11a8dbafc6d7cc46e4f8c (patch)
treedc72ebeb3b4e4fd245d5028f002f87c7d8085e59
parentd7170f449cdddffeeb9a8aa9c72cf40240278ebf (diff)
downloadpatches-0573bb5e61ed0351d4e11a8dbafc6d7cc46e4f8c.tar
patches-0573bb5e61ed0351d4e11a8dbafc6d7cc46e4f8c.tar.gz
gnu: util-linux: Do not build static libraries.
* gnu/packages/linux.scm (util-linux)[arguments]: Pass --disable-static.
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 08533742ff..c018956125 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -417,6 +417,9 @@ providing the system administrator with some help in common tasks.")
(arguments
`(#:configure-flags (list "--disable-use-tty-group"
+ ;; Do not build .a files to save 2 MiB.
+ "--disable-static"
+
;; Install completions where our
;; bash-completion package expects them.
(string-append "--with-bashcompletiondir="