summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-02-10 18:31:38 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-02-10 19:04:27 +0100
commitb8798817a18c51d372b4207fcb8fd5f2d6723dc7 (patch)
tree64cd2a2c008dd1a7b2975f447dc5994a47ae0b24
parent4c7759f027120c28d51f648d517b8cf20ed6951a (diff)
downloadpatches-b8798817a18c51d372b4207fcb8fd5f2d6723dc7.tar
patches-b8798817a18c51d372b4207fcb8fd5f2d6723dc7.tar.gz
gnu: Add java-jettison.
* gnu/packages/xml.scm (java-jettison): New variable.
-rw-r--r--gnu/packages/xml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 76b06954b4..76e44157b9 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1899,3 +1899,33 @@ with the Mobile Information Device Profile (MIDP).")
@dfn{Streaming API for XML} (StAX). It is used for streaming XML data to
and from a Java application. It provides a standard pull parser interface.")
(license license:asl2.0)))
+
+(define-public java-jettison
+ (package
+ (name "java-jettison")
+ (version "1.3.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/codehaus/jettison/archive/"
+ "jettison-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rdhfyxywvga5wiwasc04iqnxyixn3rd8wj01c9ymhvwc3h6dpqg"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "jettison.jar"
+ #:source-dir "src/main/java"
+ #:test-exclude (list "**/Abstract*.java"
+ ;; Abstract classes
+ "**/DOMTest.java"
+ "**/BadgerFishDOMTest.java"
+ "**/MappedDOMTest.java")))
+ (native-inputs
+ `(("java-junit" ,java-junit)))
+ (home-page "https://github.com/codehaus/jettison")
+ (synopsis "StAX implementation for JSON")
+ (description "Jettison is a Java library for converting XML to JSON and
+vice-versa with the help of the @dfn{Streaming API for XML} (StAX). It
+implements @code{XMLStreamWriter} and @code{XMLStreamReader} and supports
+@code{Mapped} and @code{BadgerFish} conventions.")
+ (license license:asl2.0)))