summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-10 12:06:56 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-14 14:41:38 +0100
commit77cf8b2c60438355e1891c824c763d63da5782f1 (patch)
treed746b9636b3dd1a9312678f6f72586362043cdd4
parent2aa17cef570061c1b0d0b44f3de092e8f2ecdf1e (diff)
downloadpatches-77cf8b2c60438355e1891c824c763d63da5782f1.tar
patches-77cf8b2c60438355e1891c824c763d63da5782f1.tar.gz
gnu: Add perl-crypt-des.
* gnu/packages/perl.scm (perl-crypt-des): New variable.
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e501391d97..dccc07d466 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1884,6 +1884,30 @@ decrypt messages of arbitrarily long length. The encrypted messages
are compatible with the encryption format used by SSLeay.")
(license perl-license)))
+(define-public perl-crypt-des
+ (package
+ (name "perl-crypt-des")
+ (version "2.07")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DP/DPARIS/Crypt-DES-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1rypxlhpd1jc0c327aghgl9y6ls47drmpvn0a40b4k3vhfsypc9d"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-crypt-cbc" ,perl-crypt-cbc)))
+ (home-page "https://metacpan.org/release/Crypt-DES")
+ (synopsis "DES encryption module")
+ (description "@code{Crypt::DES} is an XS-based implementation of
+the DES cryptography algorithm. The module implements the
+@code{Crypt::CBC} interface which has blocksize, keysize, encrypt and
+decrypt functions.")
+ (license bsd-3)))
+
(define-public perl-crypt-eksblowfish
(package
(name "perl-crypt-eksblowfish")