summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-01-02 17:18:59 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-05-10 22:13:54 +0200
commitec43671780af0a0e3944e4adbd116479de1eb01e (patch)
treee6e0851e075b2487a0e997781a0d5ed69c9eeef0
parent0d43b12d1dc7c5bf0d86c71de140bff37025c7c2 (diff)
downloadpatches-ec43671780af0a0e3944e4adbd116479de1eb01e.tar
patches-ec43671780af0a0e3944e4adbd116479de1eb01e.tar.gz
gnu: Add ocaml-4.01.
* gnu/packages/ocaml.scm (ocaml-4.01): New variable.
-rw-r--r--gnu/packages/ocaml.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e5e599358e..ba90071a56 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -212,6 +213,36 @@ functional, imperative and object-oriented styles of programming.")
;; distributed under lgpl2.0.
(license (list license:qpl license:lgpl2.0))))
+(define-public ocaml-4.01
+ (package
+ (inherit ocaml)
+ (version "4.01.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://caml.inria.fr/pub/distrib/ocaml-"
+ (version-major+minor version)
+ "/ocaml-" version ".tar.xz"))
+ (sha256
+ (base32
+ "03d7ida94s1gpr3gadf4jyhmh5rrszd5s4m4z59daaib25rvfyv7"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments ocaml)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'build
+ (lambda _
+ ;; Specifying '-j' at all causes the build to fail.
+ (zero? (system* "make" "world.opt"))))
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "testsuite"
+ (zero? (system*
+ "make"
+ "all"
+ (string-append
+ "TOPDIR=" (getcwd) "/.."))))))))))))
+
(define-public opam
(package
(name "opam")