summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-14 11:56:13 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-14 14:41:26 +0200
commitbbe04ae102211d6486691652a4892744ee7f9a85 (patch)
treebfd443b973245e420d3e27a7d05876d472f43dc6
parent9f7ae77fe287d7856718c5dfd60891be9b561b1d (diff)
downloadpatches-bbe04ae102211d6486691652a4892744ee7f9a85.tar
patches-bbe04ae102211d6486691652a4892744ee7f9a85.tar.gz
gnu: dbus: Update to 1.10.0.
* gnu/packages/glib.scm (dbus)[source]: Update to 1.10.0. [arguments]: Add --sysconfdir=/etc. * gnu/packages/patches/dbus-localstatedir.patch: Update.
-rw-r--r--gnu/packages/glib.scm15
-rw-r--r--gnu/packages/patches/dbus-localstatedir.patch39
2 files changed, 34 insertions, 20 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 2e8797560b..9137db3949 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -57,7 +57,7 @@
(define dbus
(package
(name "dbus")
- (version "1.8.16")
+ (version "1.10.0")
(source (origin
(method url-fetch)
(uri
@@ -65,16 +65,21 @@
version ".tar.gz"))
(sha256
(base32
- "01rba8mp8kqvmy6ibdmi806kjr3m14swnskqk02gyhykxxl54ybz"))
+ "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))
(patches (list (search-patch "dbus-localstatedir.patch")))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list ;; Install the system bus socket under /var.
"--localstatedir=/var"
- ;; XXX: Fix the following to allow system-wide
- ;; config.
- ;; "--sysconfdir=/etc"
+ ;; Look for configuration file under
+ ;; /etc/dbus-1. This is notably required by
+ ;; 'dbus-daemon-launch-helper', which looks for
+ ;; the 'system.conf' file in that place,
+ ;; regardless of what '--config-file' was
+ ;; passed to 'dbus-daemon' on the command line;
+ ;; see <https://bugs.freedesktop.org/show_bug.cgi?id=92458>.
+ "--sysconfdir=/etc"
"--with-session-socket-dir=/tmp")
#:phases (alist-cons-after
diff --git a/gnu/packages/patches/dbus-localstatedir.patch b/gnu/packages/patches/dbus-localstatedir.patch
index 61bed91b5c..921ec29be4 100644
--- a/gnu/packages/patches/dbus-localstatedir.patch
+++ b/gnu/packages/patches/dbus-localstatedir.patch
@@ -1,25 +1,34 @@
Do not try to create $localstatedir and $sysconfdir since we cannot do this
when they are /var and /etc.
---- dbus-1.6.4/bus/Makefile.in 2013-09-11 16:15:13.000000000 +0200
-+++ dbus-1.6.4/bus/Makefile.in 2013-09-11 16:15:15.000000000 +0200
-@@ -1510,9 +1510,6 @@ clean-local:
- /bin/rm *.bb *.bbg *.da *.gcov || true
-
+--- a/bus/Makefile.in
++++ b/bus/Makefile.in
+@@ -565,7 +565,7 @@ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ dbusdatadir = $(datadir)/dbus-1
+-legacydbusdatadir = $(sysconfdir)/dbus-1
++legacydbusdatadir = $(prefix)/etc/dbus-1
+ dbus_daemon_execdir = $(DBUS_DAEMONDIR)
+ DBUS_BUS_LIBS = \
+ $(XML_LIBS) \
+@@ -1669,7 +1669,6 @@ clean-local:
install-data-hook:
-- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
-- $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
-- $(mkinstalldirs) $(DESTDIR)$(configdir)/session.d
- $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
- $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/system-services
+ $(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/session.d
+ $(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/services
+-@DBUS_UNIX_TRUE@ $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
+ @DBUS_UNIX_TRUE@ $(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/system.d
+ @DBUS_UNIX_TRUE@ $(mkinstalldirs) $(DESTDIR)$(dbusdatadir)/system-services
# Install dbus.socket as default implementation of a D-Bus stack.
-
---- dbus-1.6.4/tools/Makefile.in 2013-09-11 16:10:31.000000000 +0200
-+++ dbus-1.6.4/tools/Makefile.in 2013-09-11 16:10:32.000000000 +0200
-@@ -757,11 +757,6 @@ uninstall-am: uninstall-binPROGRAMS
+diff --git a/tools/Makefile.in b/tools/Makefile.in
+index 915971d..6b6897d 100644
+--- a/tools/Makefile.in
++++ b/tools/Makefile.in
+@@ -1055,12 +1055,6 @@ uninstall-am: uninstall-binPROGRAMS uninstall-dist_examplesSCRIPTS
+ .PRECIOUS: Makefile
- # create the /var/lib/dbus directory for dbus-uuidgen
+-# create the /var/lib/dbus directory for dbus-uuidgen
-install-data-local:
- $(MKDIR_P) $(DESTDIR)$(localstatedir)/lib/dbus
-