summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-01-09 03:55:52 -0500
committerMark H Weaver <mhw@netris.org>2017-01-11 11:34:08 -0500
commit7f760a8474a7857275bdcc000ff8814b48d9c35a (patch)
treeff7fc191f3d8c20f33ca92c80281174699eedfdb
parent22753632f78873e8c539b8fe19efb77c8f722d10 (diff)
downloadpatches-7f760a8474a7857275bdcc000ff8814b48d9c35a.tar
patches-7f760a8474a7857275bdcc000ff8814b48d9c35a.tar.gz
gnu: totem: Update to 3.22.0.
* gnu/packages/gnome.scm (totem): Update to 3.22.0. [source]: Remove patch. * gnu/packages/patches/totem-debug-format-fix.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm5
-rw-r--r--gnu/packages/patches/totem-debug-format-fix.patch11
3 files changed, 2 insertions, 15 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 21580a3870..13519b0e64 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -899,7 +899,6 @@ dist_patch_DATA = \
%D%/packages/patches/ttf2eot-cstddef.patch \
%D%/packages/patches/ttfautohint-source-date-epoch.patch \
%D%/packages/patches/tophat-build-with-later-seqan.patch \
- %D%/packages/patches/totem-debug-format-fix.patch \
%D%/packages/patches/tuxpaint-stamps-path.patch \
%D%/packages/patches/unrtf-CVE-2016-10091.patch \
%D%/packages/patches/unzip-CVE-2014-8139.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 67d6b9d54d..be0687e17f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3213,7 +3213,7 @@ for application developers.")
(define-public totem
(package
(name "totem")
- (version "3.20.1")
+ (version "3.22.0")
(source
(origin
(method url-fetch)
@@ -3222,8 +3222,7 @@ for application developers.")
name "-" version ".tar.xz"))
(sha256
(base32
- "09swnhp46cyy2svqx02fzy555pjgc61lyjw56v9rz1mfc41lh8kg"))
- (patches (search-patches "totem-debug-format-fix.patch"))))
+ "1sjgjqhpsh3kipnbc8y31xz64s61xjayxq98pi0vkgbl2rdmnsh2"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
diff --git a/gnu/packages/patches/totem-debug-format-fix.patch b/gnu/packages/patches/totem-debug-format-fix.patch
deleted file mode 100644
index 7ddd31ee10..0000000000
--- a/gnu/packages/patches/totem-debug-format-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- totem-3.20.1/src/backend/bacon-video-widget.c.orig 2016-03-22 12:45:32.000000000 -0400
-+++ totem-3.20.1/src/backend/bacon-video-widget.c 2016-05-11 02:49:55.299109551 -0400
-@@ -2334,7 +2334,7 @@
- if (!gst_toc_entry_get_start_stop_times (entry, &start, &stop)) {
- GST_DEBUG ("Chapter #%d (couldn't get times)", i);
- } else {
-- GST_DEBUG ("Chapter #%d (start: %li stop: %li)", i, start, stop);
-+ GST_DEBUG ("Chapter #%d (start: %li stop: %li)", i, (long) start, (long) stop);
- }
- }
-