summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-01-06 22:15:12 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-05-10 22:13:55 +0200
commit6824387a4fb46a595006cfb17bcbb3311df6a9cd (patch)
tree8bef23e03413cae763b845c7ae0d161b200fc660
parentb32208e7b5275ea2d17b8ba9de1a5137d5a30f9b (diff)
downloadpatches-6824387a4fb46a595006cfb17bcbb3311df6a9cd.tar
patches-6824387a4fb46a595006cfb17bcbb3311df6a9cd.tar.gz
gnu: Add ocaml4.01-camlzip.
* gnu/packages/ocaml.scm (ocaml4.01-camlzip): New variable.
-rw-r--r--gnu/packages/ocaml.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e636e4eb79..ddc828095d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -914,6 +914,24 @@ JAR format. It provides functions for reading from and writing to compressed
files in these formats.")
(license license:lgpl2.1+)))
+(define-public ocaml4.01-camlzip
+ (let ((base (package-with-ocaml4.01 camlzip)))
+ (package
+ (inherit base)
+ (name "ocaml4.01-camlzip")
+ ;; Version 1.05 is the last version to support OCaml 4.01.0.
+ (version "1.05")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "http://forge.ocamlcore.org/frs/download.php/1037/camlzip-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0syh72jk9s0qwjmmfrkqchaj98m020ii082jn38pwnmb6v3p02wk")))))))
+
(define-public ocamlmod
(package
(name "ocamlmod")