summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 22:14:02 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:56:58 +0200
commit2d6e56baa78345ea90bfee9f75e311f13e397e6e (patch)
treee1043976fb4af99ad979967c563c2dd902fab128
parent59a972885c831ad0f6043a7d000ff40b28f690a8 (diff)
downloadpatches-2d6e56baa78345ea90bfee9f75e311f13e397e6e.tar
patches-2d6e56baa78345ea90bfee9f75e311f13e397e6e.tar.gz
gnu: Add python-pytest-catchlog.
* gnu/packages/python.scm (python-pytest-catchlog, python2-pytest-catchlog): New variables.
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6228f643ca..2ddc25d232 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14165,3 +14165,29 @@ pytest report.")
(define-public python2-pytest-warnings
(package-with-python2 python-pytest-warnings))
+
+(define-public python-pytest-catchlog
+ (package
+ (name "python-pytest-catchlog")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-catchlog" version ".zip"))
+ (sha256
+ (base32
+ "1w7wxh27sbqwm4jgwrjr9c2gy384aca5jzw9c0wzhl0pmk2mvqab"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (propagated-inputs
+ `(("pytest" ,python-pytest-3.0)))
+ (home-page "https://github.com/eisensheng/pytest-catchlog")
+ (synopsis "Pytest plugin to catch log messages")
+ (description
+ "Python-pytest-catchlog is a pytest plugin to catch log messages. This is
+a fork of pytest-capturelog.")
+ (license license:expat)))
+
+(define-public python2-pytest-catchlog
+ (package-with-python2 python-pytest-catchlog))