summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-02 14:39:09 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-04-03 00:14:03 +0200
commit7a9543d77ec750d93a0a7832b115db1ae83195a3 (patch)
treec0c760ff2622fd7ef718a10e68463d6f294dd2b1
parent401d28e4334dc1b9bb77af3aca6c53364dd51e1b (diff)
downloadpatches-7a9543d77ec750d93a0a7832b115db1ae83195a3.tar
patches-7a9543d77ec750d93a0a7832b115db1ae83195a3.tar.gz
gnu: lollypop: Peel off duplicate wrapper.base-for-series-3412
* gnu/packages/gnome.scm (lollypop)[arguments]: Take down some at-ats with proper module imports and prefixing. Remove the redundant ‘wrap-glib-or-gtk’ phaseis already run by the MESON-BUILD-SYSTEM.
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b29acf3225..15b5d91a0f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8887,10 +8887,15 @@ views can be printed as PDF or PostScript files, or exported to HTML.")
(base32 "1ng9492k8754vlqggbfsyzbmfdx4w17fzc4ad21fr92710na0w5a"))))
(build-system meson-build-system)
(arguments
- `(#:imported-modules ((guix build python-build-system)
- ,@%meson-build-system-modules)
+ `(#:imported-modules
+ (,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules
+ ((guix build meson-build-system)
+ ((guix build python-build-system) #:prefix python:)
+ (guix build utils))
#:glib-or-gtk? #t
- #:tests? #f ; no test suite
+ #:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-program
@@ -8901,9 +8906,7 @@ views can be printed as PDF or PostScript files, or exported to HTML.")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
#t))
(add-after 'install 'wrap-python
- (@@ (guix build python-build-system) wrap))
- (add-after 'install 'wrap-glib-or-gtk
- (@@ (guix build glib-or-gtk-build-system) wrap-all-programs)))))
+ (assoc-ref python:%standard-phases 'wrap)))))
(native-inputs
`(("intltool" ,intltool)
("itstool" ,itstool)