summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-01 18:56:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-04-01 19:05:00 +0200
commit079ffbcfaf26826adcee9bb3084794c033416d37 (patch)
treeb67475295038797463a239c7bc2c73b9eb2d9eb4
parent3853941d25fcef931225bf6adcbf663a76220ba4 (diff)
downloadpatches-079ffbcfaf26826adcee9bb3084794c033416d37.tar
patches-079ffbcfaf26826adcee9bb3084794c033416d37.tar.gz
gnu: netpbm: Use INVOKE.
* gnu/packages/netpbm.scm (netpbm)[arguments]: Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/netpbm.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/netpbm.scm b/gnu/packages/netpbm.scm
index 3e999677ba..af005c6aec 100644
--- a/gnu/packages/netpbm.scm
+++ b/gnu/packages/netpbm.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -145,7 +145,7 @@
(add-before 'check 'setup-check
(lambda _
;; install temporarily into /tmp/netpbm
- (system* "make" "package")
+ (invoke "make" "package")
;; remove test requiring X
(substitute* "test/all-in-place.test" (("pamx") ""))
;; do not worry about non-existing file
@@ -168,11 +168,11 @@
(replace 'install
(lambda* (#:key outputs make-flags #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (apply system* "make" "package"
+ (apply invoke "make" "package"
(string-append "pkgdir=" out) make-flags)
;; Remove superfluous files.
- (system* "rm" "-r" (string-append out "/link"))
- (system* "rm" "-r" (string-append out "/misc"))
+ (invoke "rm" "-r" (string-append out "/link"))
+ (invoke "rm" "-r" (string-append out "/misc"))
(with-directory-excursion out
(for-each delete-file
'("config_template" "pkginfo" "README"