summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-23 19:57:15 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-26 10:15:32 +0100
commitfd59d2ee65d6c86b115a19394d31c270cc8d95e2 (patch)
treec00dee305987a2145379ff3b372ca6c1b46b7667
parent554093b7e139ca2224b754fdeb8a3c6f2d53bde5 (diff)
downloadpatches-fd59d2ee65d6c86b115a19394d31c270cc8d95e2.tar
patches-fd59d2ee65d6c86b115a19394d31c270cc8d95e2.tar.gz
gnu: haskell: Remove CONFIG_SHELL patches.
A previous commit to the haskell-build-system made sure that if necessary, the CONFIG_SHELL environment variable is set. That obviates the individual patches applied to some packages. Remove them. * gnu/packages/haskell.scm (ghc-network, ghc-old-time, ghc-sdl-image, ghc-sdl-mixer, ghc-sdl, ghc-unix-time, ghc-x11)[arguments]: Remove ‘fix-/bin/sh’ phase.
-rw-r--r--gnu/packages/haskell.scm53
1 files changed, 5 insertions, 48 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4303093d99..652efc3fbd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -865,14 +865,6 @@ OpenAL.")
(base32
"1sa3zx3vrs1gbinxx33zwq0x2bsf3i964bff7419p7vzidn36k46"))))
(build-system haskell-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after
- 'unpack 'fix-/bin/sh
- (lambda _
- ;; Use `sh', not `/bin/sh'.
- (setenv "CONFIG_SHELL" "sh"))))))
(inputs
`(("sdl" ,sdl)))
(home-page "https://hackage.haskell.org/package/SDL")
@@ -903,14 +895,7 @@ award winning Linux port of \"Civilization: Call To Power.\"")
`(#:configure-flags
(let* ((sdl-mixer (assoc-ref %build-inputs "sdl-mixer"))
(sdl-mixer-include (string-append sdl-mixer "/include/SDL")))
- (list (string-append "--extra-include-dirs=" sdl-mixer-include)))
- #:phases
- (modify-phases %standard-phases
- (add-after
- 'unpack 'fix-/bin/sh
- (lambda _
- ;; Use `sh', not `/bin/sh'.
- (setenv "CONFIG_SHELL" "sh"))))))
+ (list (string-append "--extra-include-dirs=" sdl-mixer-include)))))
(propagated-inputs
`(("ghc-sdl" ,ghc-sdl)))
(inputs
@@ -942,14 +927,7 @@ MIDI, Ogg Vorbis, and SMPEG MP3 libraries.")
`(#:configure-flags
(let* ((sdl-image (assoc-ref %build-inputs "sdl-image"))
(sdl-image-include (string-append sdl-image "/include/SDL")))
- (list (string-append "--extra-include-dirs=" sdl-image-include)))
- #:phases
- (modify-phases %standard-phases
- (add-after
- 'unpack 'fix-/bin/sh
- (lambda _
- ;; Use `sh', not `/bin/sh'.
- (setenv "CONFIG_SHELL" "sh"))))))
+ (list (string-append "--extra-include-dirs=" sdl-image-include)))))
(propagated-inputs
`(("ghc-sdl" ,ghc-sdl)))
(inputs
@@ -1216,12 +1194,6 @@ date and time formats.")
(base32
"1h9b26s3kfh2k0ih4383w90ibji6n0iwamxp6rfp2lbq1y5ibjqw"))))
(build-system haskell-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-/bin/sh
- (lambda _
- (setenv "CONFIG_SHELL" "sh"))))))
(propagated-inputs
`(("ghc-old-locale" ,ghc-old-locale)))
(home-page "http://hackage.haskell.org/package/old-time")
@@ -1433,12 +1405,6 @@ environment variables.")
"X11-" version ".tar.gz"))
(sha256
(base32 "1kzjcynm3rr83ihqx2y2d852jc49da4p18gv6jzm7g87z22x85jj"))))
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'configure 'set-sh
- (lambda _
- (setenv "CONFIG_SHELL" "sh")
- #t)))))
(build-system haskell-build-system)
(inputs
`(("libx11" ,libx11)
@@ -1801,13 +1767,8 @@ but also need those types.")
"0dyvyxwaffb94bgri1wc4b9wqaasy32pyjn0lww3dqblxv8fn5ax"))))
(build-system haskell-build-system)
(arguments
- `(#:tests? #f ; FIXME: Test fails with "System.Time not found". This is
- ; weird, that should be provided by GHC 7.10.2.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-/bin/sh
- (lambda _
- (setenv "CONFIG_SHELL" "sh"))))))
+ `(#:tests? #f)) ; FIXME: Test fails with "System.Time not found". This
+ ; is weird, that should be provided by GHC 7.10.2.
(propagated-inputs
`(("ghc-old-time" ,ghc-old-time)
("ghc-old-locale" ,ghc-old-locale)))
@@ -3162,11 +3123,7 @@ boxed and storable vectors.")
(inputs
`(("ghc-hunit" ,ghc-hunit)))
(arguments
- `(#:tests? #f ; FIXME: currently missing libraries used for tests.
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'set-sh
- (lambda _ (setenv "CONFIG_SHELL" "sh"))))))
+ `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
(home-page "https://github.com/haskell/network")
(synopsis "Low-level networking interface")
(description