summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-19 16:04:01 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-23 08:40:14 +0100
commitc0266e8d031852931d1cc324dd56cf075cecc9a2 (patch)
tree460e117c7a3121137e6ba80621f733150cbe1b06
parentebf89f134c4978370d97de81893fd0c696180f72 (diff)
downloadpatches-c0266e8d031852931d1cc324dd56cf075cecc9a2.tar
patches-c0266e8d031852931d1cc324dd56cf075cecc9a2.tar.gz
gnu: star: Use "modify-phases" syntax.
* gnu/packages/bioinformatics.scm (star)[arguments]: Use "modify-phases" syntax.
-rw-r--r--gnu/packages/bioinformatics.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e579afe12d..485faefdc9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3037,15 +3037,15 @@ of these reads to align data quickly through a hash-based indexing scheme.")
'(#:tests? #f ;no check target
#:make-flags '("STAR")
#:phases
- (alist-cons-after
- 'unpack 'enter-source-dir (lambda _ (chdir "source"))
- (alist-replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
- (install-file "STAR" bin)))
- (alist-delete
- 'configure %standard-phases)))))
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enter-source-dir
+ (lambda _ (chdir "source") #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
+ (install-file "STAR" bin))
+ #t))
+ (delete 'configure))))
(native-inputs
`(("vim" ,vim))) ; for xxd
(inputs