summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAljosha Papsch <misc@rpapsch.de>2015-10-26 22:27:05 +0100
committerLudovic Courtès <ludo@gnu.org>2015-10-27 00:01:20 +0100
commit7e9b07bdcbe6b5339fdc70d880089282ebc82578 (patch)
tree8cb2e9a41c2b3c72287f87035abb30a75b8f2a59
parent7dae1f4301323e5789b93e04786977c87aa8c8da (diff)
downloadpatches-7e9b07bdcbe6b5339fdc70d880089282ebc82578.tar
patches-7e9b07bdcbe6b5339fdc70d880089282ebc82578.tar.gz
gnu: Add yapet.
* gnu/packages/password-utils.scm (yapet): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/password-utils.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 921ade1030..3cb319aeda 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,9 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages qt)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg))
@@ -104,3 +108,31 @@ For copying and pasting secrets into web browsers and other graphical
applications, there is xclip integration." )
(home-page "http://dthompson.us/pages/software/shroud.html")
(license license:gpl3+)))
+
+(define-public yapet
+ (package
+ (name "yapet")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.guengel.ch/myapps/yapet/downloads/yapet-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "0ydbnqw6icdh07pnv2w6dhvq501bdfvrklv4xmyr8znca9d753if"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ncurses" ,ncurses)
+ ("openssl" ,openssl)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Yet Another Password Encryption Tool")
+ (description "YAPET is a text based password manager using the Blowfish
+encryption algorithm. Because of its small footprint and very few library
+dependencies, it is suited for installing on desktop and server systems alike.
+The text based user interface allows you to run YAPET easily in a Secure Shell
+session. Two companion utilities enable users to convert CSV files to YAPET
+and vice versa.")
+ (home-page "http://www.guengel.ch/myapps/yapet/")
+ (license license:gpl3+)))