summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-01-29 23:46:33 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-01-29 23:46:33 +0100
commit4fdcc5026fb6a1fe007363eb32af891f35704e28 (patch)
tree96c2981bcccb4280e63d3d017855cf0512956ae7
parent4bca1e74989e44e05e350c361f6f686c0ab3812a (diff)
downloadpatches-4fdcc5026fb6a1fe007363eb32af891f35704e28.tar
patches-4fdcc5026fb6a1fe007363eb32af891f35704e28.tar.gz
gnu: Add dub.
* gnu/packages/ldc.scm (dub): New variable.
-rw-r--r--gnu/packages/ldc.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/ldc.scm b/gnu/packages/ldc.scm
index a1bdc586df..4b10ac25e0 100644
--- a/gnu/packages/ldc.scm
+++ b/gnu/packages/ldc.scm
@@ -28,6 +28,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages gdb)
#:use-module (gnu packages libedit)
#:use-module (gnu packages llvm)
@@ -274,3 +275,40 @@ latest DMD frontend and uses LLVM as backend.")
(patches (search-patches "ldc-1.1.0-disable-dmd-tests.patch")))))))))
(define-public ldc-beta ldc-1.1.0-beta6)
+
+(define-public dub
+ (package
+ (name "dub")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/dlang/dub/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1sd8i1rvxc7y7kk0y6km5zyvaladc5zh56r6afj74ndd63dssv43"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; it would have tested itself by installing some packages (vibe etc)
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (zero? (system* "./build.sh"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (outbin (string-append out "/bin")))
+ (mkdir-p outbin)
+ (install-file "bin/dub" outbin)
+ #t))))))
+ (inputs
+ `(("curl" ,curl)))
+ (native-inputs
+ `(("ldc" ,ldc)))
+ (home-page "https://code.dlang.org/getting_started")
+ (synopsis "DUB package manager")
+ (description "This package provides the D package manager.")
+ (license license:expat)))