summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-14 00:35:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-14 00:37:46 +0200
commitf5b1354fdb963586bb3cf0411c8bb2a3e8e7fd84 (patch)
tree8c6c782a0f57db8b25581672d3aa24e7d4ea83c7
parentcd3ba9c8c7952567d4524f67d57046f08b7ad48a (diff)
downloadpatches-f5b1354fdb963586bb3cf0411c8bb2a3e8e7fd84.tar
patches-f5b1354fdb963586bb3cf0411c8bb2a3e8e7fd84.tar.gz
gnu: Add r-lifecycle.
* gnu/packages/cran.scm (r-lifecycle): New variable.
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d85712df2c..f40d00fc94 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15479,3 +15479,31 @@ Earth radius vector, declination, sunset and sunrise, daylength, equation of
time, vector in the direction of the sun, vector normal to surface, and some
atmospheric physics.")
(license license:gpl2+)))
+
+(define-public r-lifecycle
+ (package
+ (name "r-lifecycle")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lifecycle" version))
+ (sha256
+ (base32
+ "11rk7hkw63rfrf4aqmb4xrb88kg95xh8hajpjvjfwjym2v02h74n"))))
+ (properties `((upstream-name . "lifecycle")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-glue" ,r-glue)
+ ("r-rlang" ,r-rlang)))
+ (home-page "https://github.com/r-lib/lifecycle")
+ (synopsis "Manage the life cycle of your package functions")
+ (description
+ "Manage the life cycle of your exported functions with shared
+conventions, documentation badges, and non-invasive deprecation warnings. The
+lifecycle package defines four development stages (experimental, maturing,
+stable, and questioning) and three deprecation stages (soft-deprecated,
+deprecated, and defunct). It makes it easy to insert badges corresponding to
+these stages in your documentation. Usage of deprecated functions are
+signalled with increasing levels of non-invasive verbosity.")
+ (license license:gpl3)))